I recently upgraded from Windows 8 Enterprise x64 (US English) to Windows 8.1 Pro x64 (RTM, US English) on my lab workstation. It worked mostly fine for the last few days (since the upgrade), but this morning, after plugging in a USB-to-ATAPI/SATA bridge, it started to show BSOD errors periodically with the error message "Critical Structure Corruption". I've already removed the bridge from the USB port, but the PC has crashed twice since I did that.

I've never really dealt with Blue Screen errors. I know they're often caused by drivers or hardware problems. However, I've never really worked on debugging one. To fix it, I would normally just do a fresh install, but this is not a desirable option at the moment.

I know I'm probably handing you a dearth of information with this post, but that's because I'm not sure exactly what's needed to troubleshoot this problem. Let me know what's needed and I'll do my best to provide it to you through edits to this post.


Here are the minidump (dmp) files from the C:\Windows\Minidump directory, as requested by magicandre1981.

  • 1
    can you share the .dmp files? Oct 2, 2013 at 17:26
  • 1
    copy the folder C:\Windows\Minidump to your Desktop, zip the folder and uplaod the zip (skydrive, dropbox, google) and post a link. Oct 2, 2013 at 17:31
  • 1
    Have you removed the driver for this adapter? We are going to need specific information about the BSOD beyond what you have shared. Using a BSOD viewer will point toward the actual file responsible for the fault.
    – Ramhound
    Oct 2, 2013 at 17:36
  • 1
    You say that you upgraded to 8.1. What was on the system before the upgrade? Any changes to the edition of Windows, language version, anything like that? It shouldn't matter but may provide clues.
    – user
    Oct 2, 2013 at 17:40
  • 1
    It was Windows 8 Enterprise x64, US English. Upgraded to Windows 8.1 Pro x64 RTM, US English. Another minidump is getting added to the original post. The system crashed literally right after I pressed "add comment" to reply to Ramhound.
    – nerdenator
    Oct 2, 2013 at 17:43

2 Answers 2


Well, from what I can tell, the problem is fixed. Here's to hoping I haven't jinxed it. Explanation follows.

When I said that I hadn't installed any other programs, I had forgotten about a disk burner program named Active@ ISO burner from a company called LSoft. From what I can tell, this program uses a driver named stpd.sys to interface with your optical drives in some manner. I originally downloaded and installed this program to write some Linux ISOs to disk, since I was having trouble with my installation media written in the conventional Windows burner. I installed it about 20 minutes before I had my first crash. After going through all of the troubleshooting steps, I determined that the USB-to-SATA/ATAPI bridge wasn't the problem, but apparently, some sort of issue had occurred with a USB device not properly being installed around the time of the crash as well. The drivers for this device (which I believe to be the bridge) were removed, but the crashes did not stop, continuing at approximately half-hour intervals.

As a part of the troubleshooting steps, I used Microsoft's driver verifier, which more or less looks through all of the selected drivers at boot and throws blue screens if there's any sort of problem with testing the driver. I selected all of the non-Microsoft drivers on the system that were loaded, but the stpd.sys driver was not selected, and blue screens were not being thrown at boot. They continued to be thrown during computer operation. I then looked to add more drivers, looking to see which ones had been loaded or modified right before my first crash.

Driver selection screen, showing stpd.sys as the most recent installation

This screenshot clearly shows stpd.sys as the most recent driver installed.

I then went to check out my system's event logs. Surprisingly, the driver in question had suffered an Event 4 occurrence, being explained as "Driver detected an internal error in its data structures for .". I'm not sure if this is a coincidence or not, but the errors received in the blue screens dealt with "CRITICAL_STRUCTURE_CORRUPTION".

Event 4 was thrown by the stpd.sys driver shortly before the first crash

After removal of the driver, the problem seems to have gone away. The machine has been on for the better part of three hours now without a critical failure. If this changes, I'll come back and fix this post. However, for now, it would seem that under certain circumstances (which I'm currently unable to accurately reproduce), the version of LSoft Active@ ISO burner available off of ntfs.com contains a driver named "stpd.sys" that will not work properly with Windows 8.1 Pro x64 RTM. I make no claims as to knowing whether an updated driver would work properly or not.

Thank you all for your help.

  • 4
    Congratulations! And thank you for sharing the solution with the rest of the community. My guess is that "stpd.sys" stands for "stupid" driver. =)
    – Samir
    Oct 13, 2013 at 15:15
  • 1
    Thank you @AaronMcRuer. The same thing happened to me. I just lost an entire day of work because of Active@ISO Burner.
    – L_7337
    Mar 2, 2014 at 14:46

You need to update the driver in order to use it with Windows 8.1 correctly; fortunately it doesn't immediately causes BSOD errors if you weren't aware.

Not the answer you're looking for? Browse other questions tagged or ask your own question.