I'm trying to make a symbolic link via the windows command prompt. I am using a drop box-like service called Copy. it creates a new folder which it syncs to the web and other computers that it's installed on. I want to sync my pictures folder to it without creating duplicates on the hard drive.

This is the command I'm entering, but I keep getting an error message, and i think it has to do with the space in my folder name. Please let me know if that's the problem and what i can to do fix it. thank you in advance

C:\mklink /D C:\Users\Drew\Copy myemailaddress@gmail.com\Pictures C:\Users\Drew\Pictures


Try using this for your spaces:


Or setting the path in double quotes:

C:\mklink /D C:\Users\Drew\Copy myemailaddress@gmail.com\Pictures "C:\Users\Drew\Pictures"
  • That worked! Thank you so much! Do I need to mark this thread as resolved? – user169126 Oct 4 '13 at 19:45

Just in case you need to link a name containing spaces to a target containing spaces, you need to enclose both of them in quotes:

C:> mklink /D "My Documents" "C:\OneDrive - My User\Documents"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.