9

I have a Linux ARM computer (BeagleBone Black). I am trying to do some camera streaming and need FFMPEG to do it. I have tried everything that I can think of (including following guides for compiling it in general), but have failed to compile FFMPEG (for ARM) without fatal errors.

ubuntu@ubuntu-armhf:~/ffmpeg_sources/ffmpeg$ ./configure --prefix="$HOME/ffmpeg_build" \

--extra-cflags="-I$HOME/ffmpeg_build/include" --extra-ldflags="-L$HOME/ffmpeg_build/lib" \ --bindir="$HOME/bin" --extra-libs="-ldl" --enable-gpl --enable-libass --enable-libfdk-aac \ --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx \ --enable-libx264 --enable-nonfree --enable-x11grab

ERROR: libfdk_aac not found

Does anyone know how to compile FFMPEG for an ARMv7 processor?

  • The general wisdom is that you compile it the same way you would for x86, except using a (cross) compiler toolchain for your architecture. What exact "fatal errors" are you getting? There may be a missing dependency, compiler version problem, or some other nuance. Just because you get a fatal error doesn't mean that your approach is fundamentally wrong. It just means we have to look closer at the problem. – allquixotic Oct 5 '13 at 1:29
  • Unfortunately, this type of question will almost definitely require a huge amount of back and forth discussion between us to resolve. You can continue to work on this with us here in comments, but be apprised, if you can gain 20 reputation, it would be much better to chat about this than to talk in comments. – allquixotic Oct 5 '13 at 1:30
  • Information required to begin helping you: Are you trying to compile ffmpeg on the Beagle itself, or on a standard desktop computer? In either case, which compiler are you using? The output of gcc -v would be useful. Also note any applicable information about which Linux distro you're using, the ./configure command line you pass, and the exact compiler invocation and error message that you receive (make sure not to pass -j to make to avoid obscuring the error message!) – allquixotic Oct 5 '13 at 1:33
  • if you had sufficient resources, you could compile it on the beagleboard itself. More information would help, certainly. – Journeyman Geek Oct 5 '13 at 1:35
  • 1
    Hey, look, you have 21 rep! (from question upvotes). Try coming to chat! – allquixotic Oct 5 '13 at 1:53
0

After having a lengthy discussion with @JourneymanGreek and @allquixotic on the chat, I was able to find an answer to my question. I basically just started leaving out encoders to compile until it worked!

In this case, since the error message was libfdk_aac not found, removing the part of the config file that said --enable-libfdk-aac1 did the trick

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.