2

I'm running the latest Raspbian distribution and just installed the transmission packages.

I've been unable to set it up properly because whenever I run a transmission-remote command - say, to alter some base configurations - I keep getting the same error:

$ transmission-remote -DU -c required -p 9091 -w ~/torrents
Unexpected response: <h1>401: Unauthorized</h1>Unauthorized User: deflate, gzip

I can't find any good docs or tutorials out there to troubleshoot with, and I suspect I missed out on a step in the initial setup process which has resulted in this error. I'll already tried setting a username/password, i.e.

$ transmission-remote --auth myusername:mypassword

which succeeded, but it's still throwing the same "Unexpected response" error for all other commands.

Does anyone have an idea of why this might be happening?

1

I can do it passing the user/password with flag -n

pi@raspbmc:~/torrent$ transmission-remote -a prueba.torrent Unexpected response:

401: Unauthorized

Unauthorized User: deflate, gzip

pi@raspbmc:~/torrent$ transmission-remote -a -n user:password prueba.torrent localhost:9091/transmission/rpc/ responded: "success"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.