4

A power spike broke the CPU temperature sensor on my motherboard. Memtest86+ runs fine. However, neither Linux nor Windows boots under default options. Windows simply shuts down during boot. Linux reports overheat during boot and shuts down in a few seconds. If I specify thermal.nocrt=1 in the kernel boot options, Linux will boot and work correctly.

The CPU temperature reported by the motherboard sensor is -40℃ (negative) in BIOS and 216℃ (due to integer overflow) in Linux. The CPU temperature reported by the CPU's built-in sensor is 35℃, which is correct and consistent with the idle temperature before the power spike.

It is reasonable to believe that Windows shuts down also because it sees an extremely high temperature. In order to use Windows on this motherboard, I need to disable the software overheat protection. Essentially, I need the equivalent of thermal.nocrt=1 in Windows. Is that possible?

  • 1
    Disable in BIOS, not in Windows – Nikola Dimitrijevic Oct 8 '13 at 0:11
  • I tried all thermal related options but nothing changed. Furthermore, if the shutdown were initiated by some sort of hardware protection circuit, Memtest86+ would have shutdown, and thermal.nocrt=1 wouldn't have fixed it on Linux. The shutdown is initiate by some software logic in the OS. – netvope Oct 8 '13 at 0:15
  • Am I correct in understanding that you cannot get Windows to boot at all - That is shuts down before completely starting? Have you tried booting to Safe Mode? – BillP3rd Oct 8 '13 at 0:28
  • @BillP3rd Yes, the machine powers off while Windows is loading (at this screen goo.gl/oP0M01), before it reaches the login screen. Unfortunately safe mode gives the same result. – netvope Oct 8 '13 at 0:35
  • Motherboard make and model? – BillP3rd Oct 8 '13 at 0:51
1

Apologies that I don't have it for Win8, but it should be similar to Win7 --

  • Control Panel > Power Options Click on "Change plan settings" next to the plan that is currently selected.
  • Click on "Change advanced power settings"
  • Scroll down to Processor Power Management and click the + to expand.
  • Change "System Cooling Policy". Change to "Passive" & apply.

NOTE that some systems do not have this control in this location.

disable thermal policy

It's even been youtube'd - http://www.youtube.com/watch?v=SeDh8-4-lm8

I would like to note that I think it is foolish to do this, but yes, you can disable thermal shutdowns.

  • 1
    Did you notice that, unfortunately, he can't get Windows to start? Also, this setting doesn't affect how Windows decides it's time to shutdown. It affect how Windows controls the CPU fan. (maximumpcguides.com/windows-7/set-the-system-cooling-policy) – BillP3rd Oct 8 '13 at 1:19
  • I tried that by loading the registry hive on another computer and setting ACSettingIndex=0 in the power scheme I use, but nothing changed – netvope Oct 8 '13 at 1:51
  • 1
    Sorry, I was asking the question he asked; I assumed that, since he asked about doing it in Windows, he'd take the drive to another system or otherwise set it. Otherwise, why ask how to do it in Windows? Netvope, "ACSettingsIndex" is related to sleep settings, not thermal monitoring. The passive cooling policy essentially stops Windows from managing the thermal state of the system. – Debra Oct 8 '13 at 2:06
  • @Debra In a Windows 8 VM, I changed "System cooling policy" in Power Options and the only value changed under CurrentControlSet was Control\Power\User\PowerSchemes\{GUID1}\{GUID2}\{GUID3}\ACSettingsIndex, where GUID1 is the balanced scheme, GUID2 is Processor power settings, and GUID3 is System cooling policy. This is how I figured out the registry entry that controls "System cooling policy". – netvope Oct 8 '13 at 2:22
  • The documentation is astoundingly poor. My apologies. – Debra Oct 8 '13 at 2:38
0

Changing system cooling policy worked with my Acer Travelmate 5742ZG. It was shutting down in random occasions after starting some of the installed programs.

  1. Open the Control Panel
  2. Select Power Options
  3. Click on Change plan settings next to the plan that is currently selected.
  4. Click on Change advanced power settings
  5. Scroll down to Processor Power Management and click the + to expand
  6. Change System Cooling Policy to Passive
  7. Click Apply

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.