I am using a Meraki wireless network, but I am unable to connect to a hidden SSID. I am using Windows 7.

In the past, the laptop in question has been connected successfully to DYD-VPN. However, that SSID is not listed in the Wireless Network Connection dialog. This error is occurring no matter which user I am logged on as.

I've tried to manually re-add it, but Windows is telling me that -

A network called DYD-VPN already exists

From here I choose the option Use the existing network, which tells me that the Wireless Network Connection dialog will be opened to allow me to choose the network. However, the dialog is not opened, and when I manually open it, yet again the SSID is not listed.

I have tried restarting every single access point, as well as the laptop, but still no joy.

Can anyone please suggest how I could fix this problem? Thanks.

  • You are 100% sure the hidden (non broadcasting SSID) wireless network still exist? If you have an existing wireless profile and it matched exactly to the wireless network - Windows will try to authenticate.
    – Darius
    Oct 8, 2013 at 10:35
  • Yes, I'm 100% sure it still exists. None of the details have changed either. But even if it didn't exist, Windows should still be showing it to me in the list of available networks as it was added manually, but it is not. It is however telling me that it still exists when I try to re-add it. Thanks.
    – David Gard
    Oct 8, 2013 at 11:24
  • Windows XP/7/8 ?
    – Darius
    Oct 8, 2013 at 11:26
  • Sorry, Windows 7. Will edit the question.
    – David Gard
    Oct 8, 2013 at 13:47

2 Answers 2


You can try deleting the existing wireless network. Goto the network settings and in the left pane click on manage wireless networks. Delete the existing wireless network and try to reconnect to this network.

It should work.


  • Thanks for the reply, but as I mentioned in the question, that SSID is not listed in the Wireless Network Connection dialog. Thanks.
    – David Gard
    Oct 8, 2013 at 9:51

You may try to re-install your wireless adapter driver to see if this problem could be resolved. Open device manager, find your wireless adapter, right click and select uninstall. Then you'd click "Scan for Hardware Changes" in the action menu to make windows re-install the wireless driver.

It should work.

  • @David, has the problem been solved? Thanks.
    – polone
    Oct 11, 2013 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.