After sleep and/or hibernation, I can't get my LAN connection to work. Windows reports "Local Area connection doesn't have a valid IP configuration". Disabling and enabling the adapter doesn't work just like going through windows' network troubleshooting. Only thing that helps is a reboot.

I already tried:

  • disabling "Allow the computer to turn off this device to save power" in adapter settings
  • resetting winsock and ip configs through netsh
  • updating drivers
  • removing network locations in Network and Sharing Center

I'm on a laptop with Win7 64-bit, LAN adapter is reported as Realtek PCIe GBE Family Controller.
I share the wired connection using ICS through WLAN and netsh hostednetwork to occasionally connect my phone to wifi.

5 Answers 5


Clean reinstall of LAN drivers helped.

  • solve the problem
    – Moshe L
    Nov 23, 2014 at 18:48

I run Windows 7 Home Deluxe and have an onboard Realtek PCBe Family NIC and a Netgear WNR1000v3 router. They worked great up until about a week ago, when this weird no-internet-after-sleep problem reared its weird head (no significant changes were made to the computer before the problem).

So when this problem popped up a few days ago, I simply avoided putting the machine to sleep for a while (a temporary and non-ideal solution). I finally got a chance to mess with it yesterday to no avail. After much searching of the internet, the only informed suggested solutions to this specific issue advised:

  1. Unchecking "Allow the computer to turn off this device to save power" worked for me. Navigation: Network and Sharing Center -> Change Adapter Settings -> Local Area Connection -> Properties -> Configure -> Power Management; and

  2. Reinstalling NIC drivers.

After I completed these steps, nothing changed. I did some more digging and turned up some Microsoft support articles (not very helpful) about DHCP not querying the router correctly after sleep because the default Gateway address was lost. So after waking the computer from sleep and having no internet, I checked out the internal IP address and it was set to some random value (when I checked, it wasn't even allocated on the internet). That was very strange indeed, so today I decided to go old school, and my solution worked.

Quick warning: This is only an appropriate solution if you are the router administrator (or can ask them to do this for you), otherwise, Step 1 is impossible.

My reasoning was if DHCP doesn't work, instead of getting an internal IP address dynamically, I can set it to be a static IP. In order for this setup to persist working, you'll need to 1) force your router to give your computer the same IP every time, and 2) force Windows to use a static IP and DNS server.

  1. For the Netgear router, this is easy. Go to in a web-browser and log into the router. Once there, click on the advanced settings tab and select internet setup, then select LAN setup (LAN setup or something like it will be in every router configuration menu, just click around). On this screen, you can reserve a specific IP (like or whatever) for any device. Netgear makes this easy by just clicking the Add button at the bottom and using radio buttons to select from already connected wired devices. Add your device and write down the IP address. Go back to the main router page and look for an info screen that lists the Subnet Mask, Gateway, and DNS server addresses for your router (they will be in xxx.xxx.xxx.xxx format); write them down too, you will all these values for Step 2.

  2. In Windows, go to Start -> Control Panel and select Network and Sharing Center, click on Local Area Connection (in blue) and then select Properties. You'll see several entries with values that can be changed. (Scroll down to) Click on Internet Protocol Version 4 and select Properties. Then select Use the Following IP address (radio button) and enter your computer's static internal IP (from Step 1; usually something like Then enter the subnet mask address from Step 1 (mine was, which is typical) and then the default gateway address from Step 1 (mine was, again typical). Now you need to fill in the DNS Server and Alternate DNS server addresses, which you also got from Step 1 (mine were and Tick the Validate Settings Upon Exit box and click OK.

  3. Sit back and enjoy your internet. For me, the settings validation thing told me that there were still problems, yet everything works fine. I've put the computer to sleep several times with the same happy result, functional internet upon waking. It's been 36 hours now and everything works great.

I hope this (fairly simple) fix works for you and saves you a day of frustration. (I actually use port forwarding and already had an internal IP address reserved for my machine, so all I needed to do for Step 1 was to figure out all the addresses needed for Step 2).

  • You must refer to how to write a good answer
    – clhy
    Oct 26, 2015 at 16:12
  • Thank you for the pointer; that would be a good message to put into the error.
    – PsiDoc
    Oct 27, 2015 at 19:20

When the issue occurs, is "Client for Microsoft Networks" checked in the LAN adapter properties? :)

Otherwise, like for all "Resuming from Hibernate/Sleep", first try to update the LAN network card drivers. Apart from this you could also disable power management on the LAN network card

  • Client for MS networks was unchecked. I enabled it and will check if the issue persists. But as for the rest - did you read the post or just skimmed it? The issue is with the wired connection, not wireless, and apart from that I already tried disabling power management.
    – Greg
    Oct 8, 2013 at 16:42
  • It was a typo :) Sorry for that. Corrected. In my first sentence I wrote LAN, but somehow I switched to wireless :( Oct 8, 2013 at 17:11
  • Didn't work, the problems is still there.
    – Greg
    Oct 9, 2013 at 13:33

Unchecking "Allow the computer to turn off this device to save power" worked for me. Navigation: Network and sharing center -> Change Adapter Settings -> Local Area Connection -> Properties -> Configure -> Power Management


On my Toshiba laptop, I would have no IP address after coming out of sleep or hibernation. The wireless adapter was connected to the router, but it had lost its DHCP lease. I fixed it by performing one (or both) of these steps (not sure which was the fix):

  • ensure hybrid sleep is NOT enabled in the power profile, advanced settings
  • execute this command to reset the tcpip stack (via a cmd window opened as administrator): netsh int ip reset

and reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .