The computer is custom build, no pre-installed windows.

I had windows 7 about a year ago, and had this problem then I went to windows 8, everything was fine but I decided to come back to win7 and the problem come back...

So I did a clean Windows 7 install, all up to date and then out of the blue a problem appeared.

Windows clock sometimes goes twice the speed (1 secound = 0.5 secounds in real time) and when it does and auto synchronize and reaches the time it was before for example (IRL it was 12:00 but the Windows clock says 12:10, so after synchronize it goes to normal 12:00, but when it goes to 12:10 my LAN turns off, when I do diagnose it displays that: ("Local Area Connection" doesn't have a valid IP configuration) and internet comes back).

The BIOS clock runs fine, the battery is fine (remember I just came from windows 8 that I used for 6 months and everything was fine. Also used windows before that and no such problem occurred)

I tried restarting the service and configure it, nothing helps...

I tried all the solutions I could find on the Internet like

 net stop w32time 
 w32tm /unregister 
 w32tm /register 
 regsvr32 c:\windows\system32\w32time.dll 
 w32tm /config /manualpeerlist:time.windows.com,0x4 /syncfromflags:MANUAL 
 net start w32time

even did a sfc /scannow and it found nothing wrong

Nothing helps... I cant do anything online because the time keeps going up and Internet crashes...

I don't want to spend another few hours to reinstall Windows and find out its still there...

The drivers are installed.

I am guessing its a software problem, but can't figure out what does it.

EDIT: The thing is I had windows 7 before and it worked fine until one day it just started to have this time problem.

  • If this happens on a fresh installation then its not a software problem. I would replace the battery on the motherboard. Its an inexpensive possible solution. The only other alternative to that is load up a Live Linux installation and confirm it doesn't happen there. Are you saying this is the same problem the way you describe the problem seems to indicate this is a different problem. – Ramhound Oct 8 '13 at 16:25
  • I don't have a complete answer so I will post this as a comment. There are two solutions (really one solution, two ways of doing it) I know of which MAY help resolve time drift: boot.ini with /useptimer switch and bcdedit command line using useplatformclock. You might read up on these two options (I think win7 requires bcdedit). At the very least it is an easy switch to set and you'll know right away since your timer drifts so quickly. – horatio Oct 8 '13 at 17:01
  • Ramhound - it didn't start right after I finished the installation, it started next day after all the drivers and software I use was installed. Tested everything on Linux (works fine) Also small note: the time doesn't start to go fast right after I turn the PC on, it just happens random, like after 1 hour or 30mins, even if I'm afk for few hours it happens and disappears randomly... PC is not overclocked or anything else, the battery is fine ;( – Hakashi Oct 8 '13 at 17:46
  • Windows clock sometimes goes twice the speed So if you open the Windows clock, does the second-hand rotate at double-speed? – Synetech Oct 8 '13 at 18:30
  • Synetech - Yes the arrow goes 2 seconds in 1 IRL sec – Hakashi Oct 8 '13 at 21:57

At the technet-windows-forum there is a thread which shows the same problem. Because you've tried just software-solutions, maybe you have more luck with the hardware.

  1. Shut the PC down
  2. Pull the plug out of the socket
  3. Wait a few seconds
  4. Boot PC

technet-thread & "solution"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.