I have a laptop with Windows 7 Home Premium installed, which I had to reinstall recently due to hard drive problems. Before that I had no problems using the native Firefox MP3 player to play audio files directly. If I clicked a link to a MP3 file, it would open in a new tab and start playing. But now, a window pops up asking me if I want to open it (with Windows Media Player by default) or download it. If I go to about:config media.windows-media-foundation.enabled is set to true, so it should work properly. There's no problem with my MP3 codecs since I can play MP3 files directly on Windows without problems. Here's the song I'm currently trying to play, and which I could play before reinstalling:


I really need to get it working again, is there any way to do it?

I'm using Firefox 24 btw.


According to this blog post both MP3 and H.264 are decoded through Media Foundation. I can play H.264 video, so I guess it's just a MP3 problem. I can't play MP3 audio on Web pages with the HTML5 tag either.


It's not working on another laptop with Windows 7 Ultimate x86 either, but it works in the desktop of a friend of mine also with Win 7 x64 and Firefox 24.


Have you tried to set the default program to open .mp3?

Go to Tools > Options > Applications and search .mp3

You will get two results, Go for the one with the type <audio/x-mpeg> and select Firefox as default...

... funny thing is, I don't have it. Rather, I have the QuickTime 7.6.9 plugin instead. Maybe that is your problem, as I haven't heard of Firefox having a default media player.

Your post refers only to Firefox for Android and Firefox OS, not Firefox for Desktops (that I assume you're having, due to the windows-7 flag). Although, the beginning of the post does refer that the feature is present on the Nightly builds of Firefox...

UPDATE: After some searching, I found this post on Stack Overflow (Why doesn't Firefox support mp3 file format in < audio >). As it turns out, Firefox has only support for HTML5-based .mp3 files.

  • Thanks for your answer. I've already trying setting the default program to Firefox, but I get the same window. That post was written on January and says they were beginning to implement it on Firefox Desktop and you had to manually set "media.windows-media-foundation.enabled" to true, but since then it has been added to stable (don't know in which version, but it worked for me without any changes on some version between 20 and 24). EDIT: I had already read that post, but I swear I was able to play that file in the link directly...
    – DaRk_St0rM
    Oct 8 '13 at 21:24
  • I have also seen some posts that lead me to Windows 8 and the need to have a Media Pack installed (because there are versions without it) doesn't seem to be your case though. Oct 8 '13 at 21:26
  • As of now, I can't test it properly because I have Windows XP (that seems to not support this feature) and Quicktime is superimposing on all settings. Oct 8 '13 at 21:34
  • This Microsoft blog post does show the way the media player looks like... in HTML-5. Maybe there just is no direct support for plain, simple, mp3 files. Oct 8 '13 at 21:36
  • 1
    As I said before, I'm completely sure that I could play that file before. Actually, when playing a file like that (at least for the internally supported formats like Ogg, but I guess it's the same for mp3) what Firefox does is create a HTML5 page with that audio embedded so it shows the player and plays it.For example if I open this ogg file,right-click and select "inspect element" I get this, so I think that's actually supported...
    – DaRk_St0rM
    Oct 8 '13 at 22:06

I answer to myself:

After asking twice in the Mozilla support forums I got the answer. As suggested to me here I installed Service Pack 1 and that did the trick. Now it works without a problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.