5

I have a small SSD disk with my linux system, and a large IDE disk with most of my work, that is mounted at system start. For some reason I can't seem to find files on the IDE disk using locate. I don't know if the error lies in me not giving correct flags to locate or if the IDE disk is ignored by updatedb (i.e. not indexed hence not searchable). How can I accomplish this?

I do find the files if I go to the mount folder and run

$ find . -name "my_pattern"

but it is quite slow.

4
  • 2
    Look at your /etc/updatedb.conf. It contains the PRUNEFS and PRUNEPATHS which might exclude your IDE drive. If it does, change that file so that it doesn't exclude your drive. And then run updatedb. If this doesn't work or you don't know what to change in that file, please include the line from mount that has your IDE drive, and the contents of /etc/updatedb.conf.
    – Dan D.
    Commented Oct 9, 2013 at 8:37
  • You were absolutely correct! Post it as an answer and I'll accept it, to mark that it has been successfully settled.
    – Backlin
    Commented Oct 9, 2013 at 10:03
  • (This is a dummy comment to just notify @DanD, since I forgot to do it in the original comment. I'll delete once you've seen it.)
    – Backlin
    Commented Oct 9, 2013 at 11:45
  • use fd instead, it's significantly faster than find due to parallelized directory traversal, and its output has nice color highlights
    – phuclv
    Commented Jun 6 at 3:57

1 Answer 1

6

As @DanD explainedin his comment, /etc/updatedb.conf contains settings for what paths and file systems to prune (not index). Indeed I found my mount point among those paths, and upon removing it everything worked fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .