My Samsung NP270E5V laptop came with Ubuntu 13.04 installed on it, but I cant boot from a CD/DVD or USB flash drive to install Windows 7. Pressing F2 during boot doesn’t take me to BIOS menu so that I change the boot order; it just boots into Ubuntu.

  • 3
    Maybe you aren't fast enough. Hold the F2 key, before you start the laptop. Also you can try to use FN+F2
    – Christian
    Commented Oct 10, 2013 at 10:46
  • If I remember properly, you don't have to change anything in BIOS. The ESC key will give you the boot menu so you can select the boot device Commented Oct 10, 2013 at 10:59
  • Thanx for ur responses, however, below is what has worked for me: 1.Upon powering on the laptop, press F10 2. Select the option to modify the BIOS settings 3. Go to the Boot Options screen 4. Set Secure Boot to Disabled 5. Set BIOS mode to UEFI and Legacy 6. Save settings and reboot 7. When the Samsung screen comes up again, press F10
    – ukuam
    Commented Oct 10, 2013 at 12:02
  • @ukuam you should put that in as an actual answer (you're allowed to answer your own questions) Commented Nov 13, 2013 at 18:00
  • Not the same model, but faced a similar issue. My problem was: I was using an USB Wireless keyboard on a laptop. Using the laptop's keyboard to press F2 worked for me.
    – Gus
    Commented Apr 26, 2020 at 13:09

3 Answers 3



How do you work around the UEFI BIOS issues present in Phoenix and Samsung devices where the boot process cannot be interrupted as expected with either the F2 or F10 Keys?


Also Effects: Phoenix BIOS P06AAE, Samsung NP700Z7C (NP700Z7C-S01US)

On Samsung computers, a Phoenix BIOS is present with the option to change the BIOS mode from legacy to UEFI.

However, changing to UEFI mode makes it impossible to interrupt the boot process and return to the BIOS configuration.

Normal interrupt keys don't work as expected: Escape, F1, F2, F5, F8, F10, F11, F12, Tab, etc.

Windows 10 may also get stuck in an endless Boot Loop -- if the BIOS is changed from legacy to UEFI. Windows 10 will be unable to fix its boot process, (a conflict between using the EFI system partition, and the MBR).


I resolved this issue by using an external keyboard:

In order to interrupt the boot process successfully, perhaps try:

At boot -- Spam the Keyboard's F10 and F11, (or: Esc, F1, F2, F10, F11, F12, Tab) ...

But use both keyboards -- the laptop keyboard AND the external keyboard -- simultaneously, alternately, repeatedly, fast --

However -- I was only able to get to the UEFI Boot Menu -- (I had an ArchLinux USB, (MBR Partitioned), and a Windows 10 Installation USB, (GPT partitioned).

I am unsure if this is simply a "timing issue" where I was able to "coincidentally" hit the right button, at the right time --

Or, perhaps it is a hardware interrupt issue -- where the external keyboard is necessary.

Issue Explanation:

Unfortunately, it does not appear that there is a new version of the BIOS released, (as of this post). And, there is not a way to get back into Legacy BIOS configuration from the UEFI menu.

Warning, Before Using UEFI on Samsung / Phoenix Laptops:

Obviously -- enable UEFI on Samsung laptops with caution.

This appears to be an issue with corrupted NVRAM in the BIOS, or just bad BIOS code.

Because there are no new BIOS updates regarding this issue -- I am apprehensive about re-flashing.

Note: Samsung's digital certificate for the biosupdate.exe utility is expired, and must be run from the command prompt. You can right click the .exe to view the certificate, and attempt to install into the trusted publisher store -- However, the utility won't overwrite / reset the current BIOS if it is the same BIOS version that it is being updated to.

  • I tried with an external keyboard but no luck :/
    – Natim
    Commented Jun 6, 2017 at 13:33

If your like me and using a Samsung laptop with the Phoenix BIOS.

esc or F10 worked where F2/F4 did not.


F2/F4 didn’t work for me either.

F10 and then find the app and choose “Setup” and you will get access to BIOS.

I had same problem 5 minutes ago. but now it’s fine.

  • This is the same as an answer already posted.
    – Carl B
    Commented Jan 27, 2015 at 23:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .