OS: Windows 8 x64. Mobo: ASUS P8Z77-V Deluxe.

I can't start an Access Point with my computer. I tried everything.

I tried netsh wlan commands from cmd (with Admin privileges) and it returns the following error:

C:\Windows\system32>netsh wlan set hostednetwork mode=allow

The hosted network mode has been set to allow.

C:\Windows\system32>netsh wlan set hostednetwork ssid=** key=** keyUsage=persistent

The SSID of the hosted network has been successfully changed. The user key passphrase of the hosted network has been successfully changed.

C:\Windows\system32>netsh wlan start hostednetwork

The hosted network couldn't be started. The parameter is incorrect.

After that I tried to start an Access Point via ASUS WiFi Engine. A tool provided by ASUS specifically for my motherboard. It didn't work. Then i tried other third party programs like Wi-Host, Connectify, VirtualRouterPlus. Nothing worked.

In device manager when i click "show hidden devices" under network adapters I have both "Microsoft Hosted Network Virtual Adapter" and "Microsoft Wi-Fi Direct Virtual Adapter" enabled but they aren't shown in "Control Panel\Network and Internet\Network Connections" no matter what I do.

I tried to disable my network adapters and then enable them again with no luck. I have uninstalled and reinstalled both my network adpaters drivers and ASUS Wifi Engine. Still nothing.

I also tried to use the Internet Connection Sharing method but the result is always the same, no access point.

I'd like to point out that everything else works fine, I can even connect via Wifi without an issue.

I have updated all my drivers and my Wifi Broadcom card driver is version (I also tried version before rolling back). The WLAN AutoConfig and ICS services are up and running.

Additional informations:

C:\Windows\system32>netsh wlan show driver

Interface name: WiFi

Driver                    : Broadcom 802.11n Network Adapter
Vendor                    : Broadcom
Provider                  : Broadcom
Date                      : 27/05/2013
Version                   :
INF file                  : C:\Windows\INF\oem96.inf
Files                     : 4 total
Type                      : Native Wi-Fi Driver
Radio types supported     : 802.11n 802.11a 802.11g 802.11b
FIPS 140-2 mode supported : Yes
802.11w Management Frame Protection supported : Yes
**Hosted network supported  : Yes**
Authentication and cipher supported in infrastructure mode:
                            Open            None
                            Open            WEP
                            WPA2-Enterprise TKIP
                            WPA2-Personal   TKIP
                            WPA2-Enterprise CCMP
                            WPA2-Personal   CCMP
                            Vendor defined  Vendor defined
                            Vendor defined  Vendor defined
                            WPA-Enterprise  TKIP
                            WPA-Personal    TKIP
                            WPA-Enterprise  CCMP
                            WPA-Personal    CCMP
Authentication and cipher supported in ad-hoc mode:
                            WPA2-Personal   CCMP
                            Open            None
                            Open            WEP
IHV service present       : Yes
IHV adapter OUI           : [00 10 18], type: [00]
IHV extensibility DLL path: C:\Windows\System32\bcmihvsrv64.dll
IHV UI extensibility ClSID: {aaa6dee9-31b9-4f18-ab39-82ef9b06eb73}
IHV diagnostics CLSID     : {00000000-0000-0000-0000-000000000000}

Thanks for your help!

  • " but they aren't shown in "Control Panel\Network and Internet\Network Connections" no matter what I do" They are shown only when the hosted network is started
    – pratnala
    Mar 1, 2014 at 14:06

2 Answers 2


Alright after weeks of useless attempts to fix the problem I found a way out, not really a solution but upgrading to Windows 8.1 did the trick for me. Everything works fine now.


What might be causing an issue is having any Cisco VPN software installed.

Even if it is not currently running, I have noticed that once I uninstalled "Any Connect", I could get the hosted network running.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .