I have had an ubuntu 12.10 server running for a while with dlna and samba running successfully. On a previous build, I had an sftp server running and I wanted to do it again.

First, I updated all the installed packages (but didn't upgrade to 13.04). I then installed SSH and openSSH and setup sftp. I can successfully log in to the ftp account.

Aftewards I noticed however that my default user could no longer access the mount where my raid is. The dlna still operated however, from this mount point. The owner / group of this directory was set to nobody:nobody. I wondered if something had gone wrong and tried setting the owner to my default user name. Didn't work, so I tried creating a new group, adding the user (and the sftp user for good measure) to the group, and making the group the owner of the mount point.

I performed a reset and my default user can't access ANY directories now (permission denied). Doing ls-l in the root directory shows that everything belongs to root:root.

If I elevate my permissions to the root user (sudo -i), I can access everywhere successfully.

Can anyone make any suggestions for fixing this permissions issue? I'm not sure what I've broken but it is rather frustrating.

  • when you say you tried to set the owner, what did you do, and it what way did it fail? are you able to access your home directory? – Frank Thomas Oct 10 '13 at 22:34
  • I tried to chown the directory with a command like sudo chown nick:media /raid/media. At this time, my primary user cannot access any directory, including the home folder (permission denied). – Nick Oct 10 '13 at 23:01
  • Just noticed that I am also unable to log in to the server through putty. Does this suggest an SSH problem? – Nick Oct 10 '13 at 23:02
  • it may be an app problem, but that in itself doesn't suggest many fixes. try chowning your whole home to nick:nick (with -R), and check ls -al \home again to see if it sticks. if so, see if ssh works again. most distros use 740 for homes if you need to chmod. as for your raid, after running your chown command, what is the owner now? – Frank Thomas Oct 10 '13 at 23:08
  • My guess would be that your /etc/passwd or /etc/groups got corrupted. – ernie Oct 10 '13 at 23:52

I fixed the problem by resetting the sshd_config file to default.

I followed the instructions from here:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.