I've read pretty much everything related to , but haven't found an answer to my question.

This summer I was away for about a month, and when I came back, recovering from hibernate had gone from being slow to unbearably slow. I could understand it being just one time, but ever since it's been like that. And the worse thing is that you have to sit there the whole time tapping the keyboard, otherwise it goes back to sleep and you have to do it all again.

Hybrid sleep is enabled.

Other strange-but-possibly-significant symptoms:

  • I tried disabling hibernate, the effect was that any time I tried to put the computer to sleep, it would wake up with a 'Windows failed to shut down correctly, would you like safe mode...'
  • Prior to this, when the computer went to sleep, the power button would flash. Now it doesn't.

(I'm hesitating about doing a system restore, but the last time I did a backup was 4 years ago, so I'm not really looking forwards to manually updating 4 years of changes.)


As advised by magicandre, here is one of the outputs from WPT. Is this any help? enter image description here


Writing the hiberfile.sys takes 34s:

  • < suspend time_unit="us" time_precision="us" min_reported="0">

  • < hiberwrite="34302000"

also suspending the apps before hibernation takes 12:

  • suspend="12418000"

But resume is ok. It takes 19s to read the hiberfile.sys and only 1.2 s to resume the Windows:

  • hiberread="18857000" resume="1194000">

So your issue is slow reading and writing to the hiberfile.sys. So check your Western Digital WD Blue WD6400AAKS for issues. Run a diag tool.

| improve this answer | |
  • Thanks, I did run a chkdsk which seemed ok. Another thing I tried was disabling hibernation, then running a defrag. That seems to have made things a bit better. I'll do another check on the disk though. Thanks for your time and patience. – Benjol Oct 16 '13 at 18:53

I had the problem with slow unhibernate (6 minutes/2GB RAM) after moving system to brand new Seagate Thin SSHD 500GB on Toshiba laptop with Windows XP.

A solution that worked for me was to disable system services which I considered junk: sevices from vendors other than Microsoft that seemd not critical (ie. Java Quick Start, Google Update, Serviio, Intel services and about 10 others). I don't know which of them exactly caused the problem but after doing so my unhibernate is fast again (10 seconds). I've found this article very helpful.

| improve this answer | |

I had a really really slow hibernate & un-hibernate on a laptop in the past, and putting my image on a different drive fixed it completely. Turned out that the original drive was just starting to fail. But I would suggest just trying a disk check & defrag, and see if that helps, before going into further diagnosis.

| improve this answer | |

A potential answer for other people with the same problem (found in comments here)

Open the control panel, go to performance and information tools, click advanced tools the shutdown problems are usually seen on that page but you may have to click on diagnostics-performance and that's it.

That got me this, and also a link to 'perfomance diagnostics' in the Event Viewer (none the wiser though, neither of these have been updated in the appropriate timeframe)

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.