11

For some reason, iTerm2 windows show up on every one of my "Spaces" (aka Desktops). Right clicking on its icon in the Dock and looking at "Options" reveals "Assign To: None", just like every other application. I can't find anything in iTerm2's settings that determine this behavior. How can I make it stop?

27

I got stuck with this as well and finally found it.

Preferences - Profiles - Window and towards the bottom there is a spaces drop down you can set.

2
  • That's it! I've been annoyed by this for a year now! – duckworthd Apr 13 '14 at 18:52
  • Problem with this is that it requires spaces which means you can't have a window open wide taking both monitors' space. – Pithikos Jul 28 '17 at 10:48
8

I've been having the absolute opposite problem of this post. I've rebooted and my iterm settings have the hotkey window set to every space. Anyone else encountering that?

edit: It turns out I needed to go into the dock > iterm > options > (assign to) All Desktops

I think this setting was reset after an os update.

2
  • 1
    Thanks for that. For the last year or so, I've been annoyed to no end that my hotkey window somehow insisted to stay only on the first space, and every time I pulled it up, it switched spaces. Have tried looking for the solution several times but always came up empty. This restores the desired behavior (i.e. hotkey window always comes up on the current space). Thanks a lot! – Chris Sep 2 '17 at 11:38
  • Thank you so much!! – Razär Jan 24 '20 at 15:13
2

I am not so sure if we had suffered from the same problem. My problem was: when switching from one desktop(workspace) where iterm2 resides to another desktop ( where I may want to check some documentation or browse web), iterm2 always shows on top of the new desktop and covers the application on the new desktop. This is annoying in a sense that whenever I want to switch to another desktop, I must want to use something on that desktop(which is definitely not iterm2 as iterm2 is on my current desktop) or I just want to have access to the desktop. And when iterm2 follows, it just screws my will and I need to manually hide or close it, which can be really annoying when you do the switches thousands of times a day.

And the solution to this is actually quite simple. According to my observation, as long as the iterm2 is not on the second place of the application switching list(the list that shows up when you cmd+tab), the annoying behavior doesn't appear. So what we need to do is to exclude iterm2 from the switching list. And there is a nice option to configure this in iterm2's preference panel, under the appearance tab.

Image of the exclude option

And the checkbox on the bottom most is what we want!!!

I just found out the answer now and I am so happy that I finally figured it out! I had been annoyed since 2013.

0
0

I had the same problem with iTerm2(Build 3.4.5), tried to do from dock > iterm > options > (assign to) but didn't worked

Following worked for me go to menu > iTerm2 > Preferences... OR use shortcut command,

Go to window tab in Profile Tab (Don't Go to window tab in General Tab) and select space, whichever you want to use, using Current space doesn't work sometimes so use a specific space

let me know if it didn't work we'll try to find something together, And Good Luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.