The problem is present in the whole system not only in games: desktop, chrome, games, everywhere. When I press any "input key" on a keyboard for example in desktop I can't select the file by left mouse button OR by tapping the touchpad for about one second(right button works immediately). Later on the LMB works well. There is NO delay, button is just deactivated for a second. In games that means that when I run I cannot shoot for example. When I switched LMB and RMB functions in windows control panel still the LMB is getting disabled and RMB works fine. By "input key" I mean letter or a number, keys like Alt, CapsLock, Ctrl does not affect touchpad. I do not remember that problem when I used Windows 7. USB mouse works like it should.

The problem existed when I was using Elantech touchpad driver and after I uninstalled it and used Windows 8.1 generic driver.

EDIT I installed the Elantech drivers and set values to 0 at every disable... key. But the problem is still present.



I have turned off disabling function in touchpad but it did not fix it. I know that touchpad is NOT broken down.

  1. Turned on the animated touchpad icon of elantech drivers and put it on the task bar(on a picture)

  2. When I type the letter and press the LMB the dynamic icon displays the click but it is ignored. enter image description here enter image description here enter image description here

  • I can't select the file by left mouse button Real mouse button or touch-pad button? – Synetech Oct 14 '13 at 21:20
  • possible duplicate of Touchpad does not respond when I am holding key on the keyboard – Synetech Oct 15 '13 at 14:08
  • @Synetech No this is different problem. In Windows 7 everything was ok and the answers there are irrelevant to this topic. – Yoda Oct 15 '13 at 22:21
  • When I type the letter and press the LMB the dynamic icon displays the click but it is ignored. Real LMB or tap? – Synetech Oct 17 '13 at 22:13
  • So did the AAPThreshold setting work? You deleted your post which I interpret as meaning that it did not. You didn’t answer my question about how you discovered it in the first place. Where did you read about it? Even if it doesn’t work, I’d be interested to know where it came from since there is almost no mention of it at all. – Synetech Oct 27 '13 at 21:22

This solved the problem for me with my ElanTech Touchpad on my Asus G55vw laptop:

Mouse to right hand corner > Settings > Change PC Settings > PC & Devices > Mouse & touchpad

Change the "To help prevent the cursor from accidentally moving while you type, turn off taps or change the delay before taps work" setting to "No Delay (always on)".

For some people this option is apparently grayed out. In that case the setting can be adjusted via a registry value. Go to the below registry value:


And change "AAPThreshold" from 2 (or whatever setting it's at) to 0.

You may have to reboot for it to take effect.

Nothing in the third party driver for ElanTech solved this issue. I honestly think this was some new setting introduced in Windows 8.1 for touchpads.

| improve this answer | |
  • 1
    For me this setting was overridden by my Synaptics ClickPad driver. Using your answer as guidance, I managed to turn this feature off by going to Mouse & touchpad settings > Additional Mouse Options > ClickPad > Settings > Advanced > SmartSense and dragging the "Palm Check Threshold" slider all the way to minimum. – Ninjakannon Feb 2 '16 at 23:31
  • Awesome! Thanks @Ninjakannon, I don't know why that worked for me (as pressing any key seemed to lock the touchpad up entirely, not the pad) but it seems to have done the trick – DevDave Mar 26 '16 at 11:01
  • Damn MS! This is yet another hard-to-find "parallel" settings not presenting anywhere in main Control Panel... Who does normally bother with those dumbed-down "PC & Devices" settings in a full-desktop environment??.. This answer finally solved my main gaming headache! – Van Jone May 6 '17 at 16:19
  • 1
    +1 the registry hack also fixed this issue for me on a Razer Blade 14" (2017) running Windows 10. – Johannes Aug 26 '17 at 22:58
  • The registry setting had no effect for me (that I could tell) on Windows 10. Instead, this answer solved it for me: set the touchpad sensitivity as high as it goes. – Zak Sep 23 '19 at 16:56

It’s probably your touchpad’s “accidental-click” counter-measure. The touchpad drivers has one or more settings which allows it detect what is presumed to be unintentional touchpad input.

It makes sense to check for this because as you can see below (figure 6), laptops have the touchpad in front of the keyboard, so when you are typing, your palm could press on the touchpad and move the cursor or even click the button. The drivers usually accomplish this accidental-input detection by discarding touchpad input while keys are being pressed because they assume you are typing.

Not surprisingly, this causes trouble when you want to press keys and use the touchpad at (or nearly) the same time (for example, when playing games like shooters that require you to hold keys and move the cursor at the same time).

To reduce false-positives, the detection routines usually use the touchpad input as a metric as well, for example by checking if the touch is a large area like a palm instead of just a finger. You can usually adjust the triggering threshold or turn it off altogether. In your case, you will want to try lowering the threshold; try lowering it a little at a time until you find a perfect balance for how you work.

There’s no need to mess with the registry, the setting is exposed in the touchpad’s normal configuration dialog. In your case, the Elantech drivers call it “PalmTracking” (figures 1). If that doesn’t work, then check the other accidental-click setting. Depending on your laptop and driver versions, it could be under Tapping (figure 2), called TouchCheck (figure 3), or labeled with the word “delay”. In any case, it will be exposed somewhere in the configuration applet, but you may have to actually read the descriptions or use the context-sensitive help ([?] button)

Also, check that regular tap-clicking isn’t being interfered with by the dragging function (figure 5). If you have that set too low, it might be trying to initiate a mouse-drag instead of registering a mouse-click.

Figure 1: Screenshot of PalmTracking settingin Elantech driver in Windows 8

Screenshot of PalmTracking setting in Elantech touchpad drivers in Windows 8

Screenshot of Elantech Tapping setting

Figure 2: Screenshot of Elantech Tapping setting

Screenshot of Elantech Tapping setting

Figure 3: Screenshot of TouchCheck setting

Screenshot of TouchCheck setting

Figure 4: Screenshot of touchpad delay setting

Screenshot of touchpad delay setting

Figure 5: Screenshot of touchpad-drag setting

Screenshot of touchpad-drag setting

Figure 6: Photo of laptop keyboard with touchpad below

Photo of laptop keyboard touchpad below

| improve this answer | |
  • As before no effect at all I've done it already earlier, but now I did it again. Driver settings has no effect on that behaviour whatsoever. But thank you for effort. – Yoda Oct 15 '13 at 21:22
  • So you have turned off PalmTracking? Have you tried the other settings like Sensitivity, Lock-Dragging, and Tapping? – Synetech Oct 17 '13 at 0:38
  • I solved that and it have nothing to do with 3rd party mouse driver. It is standard setting in Windows 8.x and you have to find proper key in registry and set it to 0. – Yoda Oct 17 '13 at 21:26
  • Who said anything about a 3rd party drivers? ಠ_ఠ And if it is a “standard setting” in Windows, then why did you have to “find” it and modify a registry entry (and one for the Elan drivers at that)? If it were a “standard setting in Windows”, then it would have been in the standard mouse control panel applet. – Synetech Oct 17 '13 at 22:42
  • i should say, how beautiful your answer is, plenty of info and images... i have a dell xps l521x and 2 delays should be turned off, first was a setting on "dell synaptic driver" and the other was the default windows 8 delay (( there is a value on mouse settings, press Wn + Q, then type "mouse" )) – AgelessEssence Nov 12 '13 at 9:15

On my Windows 10 laptop, the proper setting to allow simultaneous use of the keyboard and the touchpad's left mouse button is:

Settings > Devices > Touchpad (left nav) > Touchpad Sensitivity (dropdown) > Most Sensitive

| improve this answer | |
  • 1
    Not sure why you were downvoted. I found the same on my laptop (ThinkPad X1E). I think MS has migrated the palm check sensitivity setting to this Touchpad sensitivity setting, and Most sensitive is the only one that doesn't result in a keyboard -> mouse delay. – Artem Russakovskii Nov 14 '18 at 8:05
  • 1
    This seems to be correct for newer versions of Windows 10, and you can see that changing this value also changes the AAPThreshold registry key mentioned in another answer. However, this only affected tap-to-click and not the actual left-click button for me. – kbolino Mar 21 '19 at 7:47
  • 1
    The behavior I saw (touchpad buttons disabled by keyboard) may have been a bug in the driver. I updated to a newer Synaptics Touchpad driver (version and now the left-click button always registers regardless of the sensitivity setting (which is what I wanted; it's hard to accidentally press a button). – kbolino Mar 21 '19 at 8:06
  • 1
    I was confused as to why searching for "delay" highlighted this menu in the settings as it doesn't seem like it should be related. – Zak Sep 23 '19 at 16:52
  • I know that I shouldn't write this in a comment.. But this really made my day! Only thing that worked on my Elitebook 840 G6 after 4-5 hours of trying... Thanks! – Andreas Apr 20 at 20:16

This is the setting to disable the touchpad-click when you type. Depending on the driver installed for the touchpad, you might disable it in the touchpad properties.

I.e. on my laptop, I'd use Control Panel > Mouse, go to the Tapping tab, and there is a box for "Tap off when typing", and then a configurable delay if the box is checkmarked.

For the Elantech driver, it appears to be 1.Click Start and then Control Panel. 2.In Control Panel, click on the Mouse icon. Note: If the Control Panel is in Category View, under View by, click either Large icons or Small icons. 3.From the Mouse Properties window, click on the ELAN tab. 4.Click on the Options button.

Another way to get at it is explained here: http://wj32.org/wp/2012/12/19/asus-ux31e-setting-up-the-elantech-touchpad-driver-for-windows-8/

(You want paragraph 8) -- "8.To disable annoying behavior where the touchpad freezes up when you’re typing: set the values of DisableWhenType_DelayTime_Gesture, DisableWhenType_DelayTime_Move, DisableWhenType_DelayTime_Tap all to 0."

| improve this answer | |
  • Thank you. I would not like to use Elantech drivers cause they do not recognize RMB + LMB pressed at the same time and I do not have this "Tap off when typing" postimg.org/image/59q8824aj I know its in polish but the general look may say something. I do not even have "tapping"(in polish) here. Maybe I can modify the MS driver from regedit? – Yoda Oct 13 '13 at 11:02
  • You probably can change it in the registry, but I'm not sure where it would be for a different driver. I would suggest checking all possible mouse settings first, in case it's on one of the tabs. – Debra Oct 13 '13 at 16:11
  • I have edited the post, please look, thank you! – Yoda Oct 14 '13 at 21:14
  • Much improved, but you should include the laptop model too. I think at this point you will be better off to go to the Acer site and download the appropriate driver for your touchpad: it will be either Alps or Synaptics. The latter always seems to have settings for "disable touchpad when I type" and so you'd be able to control it; the former varies. Make sure you download the right one for your specific laptop, though! The other possibilities that I can think of are is if there are touchpad settings in the BIOS, or if you installed something like Touchfreeze at some point. – Debra Oct 14 '13 at 23:52
  • I have just installed Windows 8.1 last week, I have edited the original post. I have downloaded and install original drivers for my laptop at first and then I tried older/newer ones, now I did install newest again. – Yoda Oct 15 '13 at 21:31

I just had the same issue with Windows 10 after upgrading my notebook from Windows 7.

After looking for a solution i found a setting in the modern UI setting that caused the delay. Just press the windows key and then type "mouse" and open the modern mouse settings dialog. There you will find a setting for mouse delay (see screenshot). Maybe there is as well such a setting in Windows 8.1.

Mouse delay setting marked in red

| improve this answer | |

Ok the real solution is:

  1. Open the registry.
  2. Go to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\PrecisionTouchPad
  3. Set "AAPThreshold" to 0.
  4. Reboot.
  5. Done.


  1. You cannot turn it off by any menu beside registry editor.
  2. It is default windows setting.
  3. Drivers cannot override this behaviour.
| improve this answer | |
  • Like I said, you don’t need to edit the registry; that settings is in the configuration dialog. – Synetech Oct 17 '13 at 22:50
  • @Synetech No it is not, if so show it please. – Yoda Oct 17 '13 at 23:49
  • I don’t have your system, but it is probably in the [first tab]. If it is not there, then maybe the Polish version restricts the software. If that’s the case, then you should email Acer/Elantech to complain that it has a bad default setting without making it easy for you to change it. – Synetech Oct 18 '13 at 0:19
  • @Synetech READ WITH UNDERSTANDING please. Elantech has nothing to do with that, this is WINDOWS default setting. There is NO connection between any vendor of any touchpad in the world and that setting. There is no way to change it instead of doing what I have pointed above. – Yoda Oct 18 '13 at 0:29
  • Where did you find that setting? There is no information about it anywhere. Even the registry key has only one, same result, and that is about a completely different problem from yours. How did you find that registry entry? If it is indeed a Windows setting, then check this location (figure 5). That’s a Windows setting page and it includes the delay setting. It probably corresponds to the value you specified. – Synetech Oct 18 '13 at 1:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.