1

Yesterday I decided to boot windows for the first time in few months and I am getting too much Disk I/O(100% almost always).

I am worried about my hard drive so I really need to fix this. The hard drive light on my laptop is always on and here is task manager screenshot:

enter image description here

On linux, it is almost always 0%(obviously) but System and Service host on windows is killing my hard drive

  • you might want to hit the > next to service host. – Journeyman Geek Oct 13 '13 at 22:27
0

If you haven't booted it in months, the most likely thing is that it's simply installing updates. See what happens if you turn off the automatic installation of updates, i.e. does the disk quiet down?

  • Open the Windows 8 Control Panel. One way to get to the Control Panel is from the shortcut on the Apps screen; you can also use the Power User Menu.

  • Click or tap on the System and Security link.

  • In the System and Security window, click or tap on the Windows Update link.

  • With Windows Update now open, click or tap the Change settings link to the left.

    This will open a window with a Choose your Windows Update settings heading. Turn off the automatic download & installation (choose "Never check for updates"), and see if the system quiets down.

Of course, you could have other programs pushing updates too, but this is the most likely issue.

  • I actually did turn completely off updates but I still have the same issue. But in case of updates, would it really read/write that much? – khajvah Oct 13 '13 at 20:23
0

I have also had this issue on my own machine, and I have seen others running 8.1 with the same issue. As Debra suggested, Windows background updates can cause this, but if it is a consistent problem then it may be something further.

If you open Resource Monitor, go to Disk and open Disk Activity. Here you can filter by Total Read/Write bytes per second, and it might help you narrow down which processes are accessing the disk so much.

Edit: refer here for some more help. It seems to be a Windows 8.1 problem.

0

tldr; Install driver for CHIPSET.

Only if you have the beta version of Window 8 or the initial release of 8.1. Based on the screenshot provided it is one of the 8.x OSes. For some reason it didn't come with drivers for some chipsets (a chipset is not a hard drive). This is fixed with windows updates. Also, this update option is only available if manually selected. Automatic updates will pull the option to download it but won't actually download and install it unless the check box is marked.

Wait my drivers must be fine because I can get to my files and my hard drive works???

That isn't quite accurate. Your hard drive could be using a "Generic" or "Proprietary" driver but that doesn't seem to fix your problem? So, you can move files back and forth but you may be maxing out your disk for no easily identifiable reason? The issue isn't always with that driver. Sometimes it is the "Chipset" driver. Other times it is that the BIOS/UEFI configuration needs to be set to either AHCI or IDE. Look at your hard drive manufacturer documentation for which mode should be enabled for that specific drive.

Maybe look at: https://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&changeLang=true&DwnldId=20775

But that should be pulled down as an update option but remember "click the checkbox". Then let it Download and as part of the installation process windows makes you reboot your computer. Then check Disk I/O.

So a review:

  • AHCI OR IDE IN BIOS/UEFI
  • HDD DRIVER &&&& CHIPSET DRIVER
  • REBOOT
  • TEST DISK I/O

Other options that I have not tested personally: Windows 8 extremely high disk usage and slow IO

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.