I have an HTPC with an Asus E45M1-M PRO motherboard, with Windows 7 installed. I prefer to sleep/resume this PC for minimum lead time when using it. However, currently if I resume from sleep on this PC, the desktop will show up as normal, and will look ok until I try to interact with anything (click the start button or a window). Windows does not respond to these clicks. If I mouse over the task bar, the loading cursor is usually shown. Keyboard shortcuts don't work either - no response to Ctrl-Alt-Delete. Eventually (after about 3 minutes), the system "catches up" and responds to everything that I've done while it was locked up. This problem has been occurring since the initial OS install.

Things I have already tried:

  • updated graphics and chipset drivers (including LAN drivers from the Realtek website).
  • this system also uses a remote control system from Soundgraph using the iMon software. I have tried disconnecting the device from the motherboard and uninstalling the software.
  • tried disconnecting the network cable to determine if it was hanging while resolving its address.
  • BIOS is up to date.
  • Hybrid sleep has been turned off and USB selective suspend setting is disabled.
  • changing display from HDMI (TV) to D-Sub (monitor).
  • ran the Windows memory diagnostics (I vaguely recall running Memtest86+ back when I first encountered the issue, but I may need to run it again to be sure).
  • running a "clean boot" using msconfig.
  • stress tested the CPU for three hours using Prime95 [15/10/2013]
  • disabled turning off hard disks in power settings [24/10/2013]
  • disabled hibernation and performed an SFC scan per Dave Rook's answer [24/10/2013]
  • ran a full hard disk scan [24/10/2013]

There are a number of events in the event log: "A timeout (30000 milliseconds) was reached while waiting for a transaction response from the XXX service." With a variety of different services, so I suspect that it's another symptom of the hang rather than an indication of the cause.

What further steps can I take to diagnose and fix this issue?

  • Just to try, please change your power options and see if the issue continues – Dave Oct 14 '13 at 7:45
  • @DaveRook can you be more specific? Do you mean the Windows power options? Which ones? As mentioned in the description, I've turned off hybrid sleep and disabled USB selective suspend. – tvStatic Oct 14 '13 at 21:09
  • Yes I did mean windows power options. Don't use any power saving options. – Dave Oct 15 '13 at 5:33
  • Does it stay slow, or is it perhaps pulling from a swap file for a short while? – SDsolar May 8 '17 at 23:49

It seems that any of the system file is corrupt you may use the System File Checker tool (SFC.exe) to determine which file is causing the issue, and then replace the file. Follow the link given below for the same.

How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7


You may also update the chipset drivers from the manufacturer’s website and check if that is of help.

Refer to:

Update a driver for hardware that isn't working properly


Update drivers: recommended links

Step 1 :

To resolve this issue, change the following BIOS power-management options on your computer:

  1. Restart your PC

  2. Then keeping tapping Bios selection Key on Keyboard (Ex. F12 for Dell, F2 for AMI)

  3. Then in power management check this below things

    From advanced Set the Battery Mode or BIOS Power Management option to User Setting instead of Full Power. Change the CPU Sleep Mode option to Disable. Change the Processing Speed option to High. Change the Cooling Method option to Performance.

Step 2:

Try disabling Hibernation and this will remove hybersis file. After this try enabling Hibernation and check because Hybersis file may be the issue.

Please click an this Link for How to Enable and Disable Hibernation

Step 3:

Try performing SFC scan.

You can try this to check if any system file is damaged and this can be replaced by SFC.

  1. Click Start, click All Programs, click Accessories, right-clickCommand Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type thepassword, or click Allow

  2. Type the following command below, and then press ENTER:

      sfc /scannow
       A message will appear stating that 'The system scan will begin'. Be patient because the scan may take some time
  3. If any files require a replace SFC will replace them. You may be asked to insert your Win7 DVD for this process to continue

  4. If everything is okay you should, after the scan, see the following message "Windows resource protection did not find any integrity violations"

  5. After the scan has completed, close the command prompt window,restart the computer and check.

Source for both

  • Thanks. I have now tried all of this, except for the BIOS settings, which were not present in my BIOS. I have updated the original question to show this. – tvStatic Oct 25 '13 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.