3

When I execute a command that gives huge output, infact it is log of a running server, I see that PowerShell ISE output pane is automatically wrapping the text to around half of the screen width when the tab in which the command is running is not active. Is there any way to avoid text wrap in PowerShell ISE output pane. Following are the sample screenshots.

Below screenshot is the Output when the tab running this command is active.

Output the tab running this command is active
(Click images to enlarge)

Below screenshot is the Output when the tab running this command is not active.

Sample when the tab running the same command is not active.

I have tried to pipe the output to Write-Host with a -nonewline flag, but that seems to merge all the lines into single line, so that doesn't help me. I have also tried setting $Host.UI.RawUI.BufferSize.Width to 500, but this doesn't seem to help me. Can anyone help me find out what the problem is and how to fix it?

1

This seems like a bug in Powershell. Please upgrade it to Powershell V3.0 by following this link. Powershell 3.0. This also fixes many other issues like not being able to use some color combinations in powershell output pane by using Write-Host etc., However, please be noted that upgrading to 3.0 cannot be reverted back and the scripts are not completely compatible between versions either, you may have to do slight modifications to your existing scripts if you are using outputpane in the scripts as output pane is no longer available in powershell. It needs to be replaced with consolepane.

  • 1
    This worked for me. However, I'm not sure, how useful it is for others as not everyone will be able to update their machines as some will rely on organisations to do the necessary updates. – Buddha Oct 14 '13 at 12:48

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.