Environment: Windows 8.0 Professional x64

When I call up the context menu on a selected folder in the listview (actual view mode doesn't matter, I reproduce for list, icons, and details), either via right-click or the context-menu button on my keyboard, the menu appears and then vanishes a second later.

It doesn't happen for all folders. It doesn't happen for drives. It doesn't happen in the folder tree pane.

If it happens for a folder inside a Documents library, it happens for both paths rooted at Libraries and filesystem paths.

The effect is similar to this question but I am in a different environment and it's happening to different folders.

I presume that a shell extension is causing an error/exception during context menu processing, and Explorer responds by destroying the menu. Are such errors logged anywhere? How can I discover what extension is failing?

The laptop where I'm observing this does suffer from Task Manager sporadically closing itself on launch, and also instability caused by overheating, but this problem is 100% reproducible so I don't think it is heat-related.

  • Sounds like the Escape key is stuck. What happens if you select a file and press Ctrl+X? Does its icon turn faded and stay like that? What happens if you press Win? Does the Start menu open and stay open? – Synetech Oct 15 '13 at 4:31
  • @Syntech: I don't think a stuck escape key would cause symptoms that it only occurs on folders, not file context menus or drive context menus, and it also doesn't occur in the folder tree, only in the listview. BTW Windows 8 doesn't have a Start Menu. – Ben Voigt Oct 15 '13 at 4:41
  • I was looking at the other question you linked to, but the question stands; what happens when you cut a file? Does its icon remain faded for more than a few seconds? It might indeed be an extension. – Synetech Oct 15 '13 at 5:27

It doesn't happen for all folders. It doesn't happen for drives. It doesn't happen in the folder tree pane.

Is there anything different between the folders it happens with and the ones it doesn’t (e.g., do some contain media files or desktop.ini or have different attributes set or something)?

I presume that a shell extension is causing an error/exception during context menu processing, and Explorer responds by destroying the menu.

If you can definitively rule out the Escape key and narrow down the problem to just the context-menu of folders, then it is indeed likely one of the folder-only shell-extensions. Like you surmised, what’s probably happening is that something you installed recently added a context-menu to folders, but the context-menu handler is poorly written and has a bug, so whenever it triggers, it is causing a problem, probably while trying to create a submenu or use an icon. (You’re lucky that all it’s doing is closing the menu and not outright crashing Explorer.)

Are such errors logged anywhere?

It don’t believe that there is specifically a shell-extension-failure logging function, but you can check the Event Log (Runeventvwr). If there’s anything, it will probably be under the Windows Logs ⇨ Applications branch, possibly with a source of Application Popup or Application Error.

How can I discover what extension is failing?

You can use ShellExView to determine which extension is the culprit.

  1. Run ShellExView
  2. Click the File Extensions column to sub-sort by hook
  3. Click the Type column to sort by extension type
  4. Scroll down to the entries that contain Folder or Directory in the File Extensions column (look carefully because they can be mixed in with a bunch of other hooks; you can check the entry’s Properties dialog to see the field in a navigable edit control)
  5. Disable one (right-click ⇨ Disable or select, F7)
  6. You may need to restart Explorer.

Test to see if it still happens. If so, repeat for the next one. You can also disable multiple/all items by holding the Ctrl key, but then you would have to re-enable them one-by-one to determine which one was causing the problem, so you may as well disable them one at a time.

Screenshot of context-menu handlers in ShellExView

  • I'd already tried disabling a bunch of extensions, and restarted explorer, and that didn't help. I did notice that it seemed to only happen within subversion working copies. I have TortoiseSVN installed, but that's a shell extension that I can't do without (it fact inability to reach its menus triggered this question) and it hasn't been installed or updated recently. As I said, restarting all explorer.exe processes did nothing. But the problem mysteriously went away after reboot. My best guess now is that the TortoiseSVNCache.exe helper process was stuck in a bad state. – Ben Voigt Oct 15 '13 at 14:19
  • Ah, that narrows it down some, and that would have been my guess as well. Is it running? Have you tried simply killing TSVNCache.exe? (It restarts as soon as you right-click a folder.) – Synetech Oct 15 '13 at 14:22
  • Well, TSVNCache obviously got killed by the reboot, and the problem hasn't come back. If I ever see it again, cycling TSVNCache.exe will be my first step. – Ben Voigt Oct 15 '13 at 14:28
  • Just make sure to test the context-menu before and after as a diagnostic step to determine if it is indeed TSVN. ;-) – Synetech Oct 15 '13 at 14:29
  • report this to the TSVN developers so that they can investigate it. – magicandre1981 Oct 15 '13 at 17:07

You can only figure out which extension it is, by trial & error.

Use ShellExView and disable 3rd part DLLs until you find the one which causes it.

  • It works after restarting Windows Explorer :) – BullyWiiPlaza Apr 24 '16 at 17:51

Go to the folder which causes the trouble. Right click on it. Go to Properties and then go to customize and in it you will find a heading as " optimize this folder for", there select as " general items" and apply. This eliminates the problem and folders work fine without any limitation or drawback.

  • 1
    Thanks for the tip; I'll definitely try that if the problem rears its ugly head again. – Ben Voigt Dec 16 '15 at 16:02

In my case the reason was Google Drive Backup & Sync was running. As soon as I stopped it, my context menu was not disappearing anymore.

  • 2
    That is a program I have installed (well, it wasn't Backup and Sync back when I posted the question, just Google Drive, but it's basically just 2 versions of the same program) so it easily could be the troublemaker. Thanks for narrowing that down. – Ben Voigt Feb 27 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.