2

I'm somewhat bothered by the needless presence of a scroll lock indicator and a touchpad toggle in my system tray (since Windows 7 also known as a notification area).

Specifically, the two ugly icons in the bottom of the overflow:

VAIO Control Center notifications

The mouse-over for these tray icons reads "Scr Lk Off" and "Touchpad: On", respectively, and the Windows Notification Area Icons window reveals that they're associated with VAIO Control Center.

I've already moved them into the overflow, but choosing "Customize..." and setting both associated options to "Hide icon and notifications" appears to have no effect.

I cannot fathom why anybody would use this, as there are function-key shortcuts for both these options. (Although there's no indicator for scroll lock, I really couldn't care less what its setting is as I've in 20 years never found a use for it.)

Is there any way to get rid of these system tray icons?

2

I figured out that the application responsible for these two icons is a background service called "VAIO Event Service", which is started with Windows. It's generally not a good idea to stop this service, because in doing so, various shortcut keys stop working. The service description also mentions that power management is disabled.

Simply put: the icons cannot be disabled without losing some functionality of your VAIO notebook.

It may nevertheless be insightful to share how I figured out which app was responsible for the icons:

  1. Firstly, to get some more information about the application responsible for the tray icons, I expanded the notification area and clicked "Customize..." to open the Windows Notification Area Icons window. From there, I determined that the application name is "VAIO Control Center".
  2. I then used Sysinternal's Process Explorer to review all running tasks that contain that application in the description column. Sure enough, there was a match. In the mouse-over tooltip, the match revealed that it was associated with a service.
  3. In the Windows Services window, I located that service and stopped it. The icons immediately disappeared from my tray, but I could no longer disable the touchpad with the Fn+F1 shortcut.
1

Try running msconfig from the run menu (Windows+R). From there you may be able to see what is launching the offending applications. Try unticking the relevant entries, clicking OK and restarting your laptop.

  • Thanks for your reply. As this is Windows 8, that has migrated to the Task Manager. I've reviewed the list, and the VAIO Control Center doesn't appear to be launched in that manner. I suspect it is a system service running in the background, also responsible for the volume & brightness overlays, and controlling various hardware tidbits, like the keyboard backlighting. – Paul Lammertsma Oct 14 '13 at 21:16
  • 1
    In that case the fall back position is to use Autoruns: technet.microsoft.com/en-gb/sysinternals/bb963902.aspx It suggests it still works with Windows8 although I don't have a Windows8 PC here to test that on. – sahmeepee Oct 14 '13 at 21:43
  • A bit of testing later, and I've discovered that the service responsible for these icons is the VAIO Event Service. Stopping it indeed removes the icons, but also various shortcut keys stop working. The service description also mentions that power management is disabled. – Paul Lammertsma Oct 14 '13 at 22:16
  • @PaulLammertsma post your finding as answer and mark it as answer. – magicandre1981 Oct 15 '13 at 4:37
  • @sahmeepee Thanks for setting me on the right track. – Paul Lammertsma Oct 15 '13 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.