I have been having trouble with my Windows installation lately so I tried blanking a user's password using the Linux utility chntpw. When this did not work, I tried promoting another user to Administrator, at which point I got a warning that I may experience strange behavior because this feature is experimental and changes the Windows registry.

I used chntpw anyway, operating on the file C:\Windows\System32\config\SAM

When nothing worked, I googled around and found that Windows keeps regular copies of its registry hives in C:\Windows\System32\config\RegBackup. So I used the SAM file in there to restore user passwords to a sane (and functional) state. At this point, I could log in with my regular user account normally. Everything seemed fine until I noticed two very strange problems:

  • Explorer opens a new window for each folder even though I specifically opted for "Open each folder in the same window" in the Folder Options.
  • Most .exe files can't be run. Whenever I do that, I get a message that the file is not found. I get this same behavior even if I don't rely on the PATH variable and call the executable by absolute path from the command prompt. Now this question here and other Internet resources have suggested that this is due to a messed up registry key. I'm inclined to believe this in light of the earlier chntpw warning. The only problem is, I can't launch regedit.exe: I get the same "Not found" error.

What I have tried

  • I thought that this regular backup thing Windows does is nifty and I can thus restore all the modified registry hives from backup so I used my Linux's find to get a list of the hives I had modified today and found that these were SECURITY, SOFTWARE and DEFAULT. Restoring all of them from backup didn't help however, and here I am.

What can I do to restore my registry to a sane state so that I may run executables again?


  • Some executables work. I tried mspaint, calc and cmd and all work successfully.
  • I suggest you backup your files and install a fresh windows installation and in the future take heed to the warnings
    – Ramhound
    Oct 14, 2013 at 23:42
  • @Ramhound Not an option unfortunately. This is an OEM install and I have no disk for it.
    – Joseph R.
    Oct 14, 2013 at 23:47
  • You can get a disk from the OEM and/or use the recovery partition
    – Ramhound
    Oct 15, 2013 at 0:55
  • @Ramhound How do I go about recovering from the recovery partition?
    – Joseph R.
    Oct 15, 2013 at 1:10
  • That would depend on the OEM
    – Ramhound
    Oct 15, 2013 at 2:25


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.