0

For some reason, Notepad++ has performance issues when I open a file containing a very long line (+40M characters).

The total size of the file is approximately 60 MB. I have to wait several seconds each time I move the cursor.

Is there a time consuming option I should disable? No syntax highlighting is enabled.

  • Try toggling line wrapping and see if it helps. I think the biggest problem is simply attempting to measure the line width for the horizontal scrollbar. The Scintilla editing component that N++ (and many other editors) use simply doesn't consider extremely long lines to be a worthwhile use case to optimize performance for. – afrazier Oct 16 '13 at 13:47
1

60 MB is quite a big size for a text editor . It will take some time to open such a large file and there is no other way to speedup this process

  • I becomes a lot faster if you disable line breaks and syntax colouring, but even then rendering the text takes quite some time. – David Foerster Oct 16 '13 at 13:36
  • As a side note, this was the reason I switched to Sublime Text. It was able to open larger file sizes without freezing nor affecting other documents on other tabs. – Cardin May 8 '15 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.