2

I'm using Ubuntu. I performed the following commands in the vim source folder:

sudo apt-get build-dep vim
./configure --with-features=huge --enable-gui=gtk2 --enable-rubyinterp=yes --enable-pythoninterp=yes
make
sudo make install

I have found that related posts but fail in Ubuntu 13.04.

Here is the error after do the .configure

checking --enable-gui argument... no GUI support

How can I let the system to find the GUI library? I have tried to do

apt-get build-dep vim

The gui lib should be included, but no luck what else can I do?

I have also tried

--enable-gui=<auto, gtk, gtk2, gnome2>

All of them show the same error no GUI support...

More update and try

kithokit@12:39:06 ~ $ sudo apt-get build-dep vim-gtk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Picking 'vim' as source package instead of 'vim-gtk'
0 upgraded, 0 newly installed, 0 to remove and 42 not upgraded.

vim-gtk can not be installed...

I have already installed build-dep vim, but also no luck to find the GUI library.

  • 8
    We can't read your mind nor your screen; what's the error you get? The basic steps look fine. – Ingo Karkat Oct 16 '13 at 10:27
  • 2
    "I have found that related posts but fail in Ubuntu 13.04". What does it mean? – That Brazilian Guy Oct 23 '13 at 14:32
  • 1
    You had the effort to set a bounty on the question, yet you decide not to provide us one of the most valuable piece of info: the error message. – That Brazilian Guy Oct 23 '13 at 19:12
  • Sorry for the insufficient info provided. I have updated my question – Kit Ho Oct 24 '13 at 3:21
  • Do you have the development packages for GTK2/GNOME2 installed? If configure can't find them it will not enable building with the GUI. – Heptite Oct 24 '13 at 3:50
7

I got the solution from this page http://vim.wikia.com/wiki/Building_Vim

the problem i can't get the GUI lib is that i have build the vim without GUI before.

And i use make clean instead of make distclean to rebuild the vim with GUI even the GUI lib installed. so the solution would be

sudo apt-get build-dep vim

make distclean

./configure --with-features=huge --enable-gui=gtk2 --enable-rubyinterp=yes --enable-pythoninterp=yes

make

sudo make install

I hoep it can help others

| improve this answer | |
  • 1
    Did you mean "distclean" and not "diskclean"? – Heptite Oct 24 '13 at 17:44
  • change back . thx – Kit Ho Oct 28 '13 at 1:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.