0

EDIT: My problem is solved, please read comments 2-5 and 8,9.

I have an EasyN F3 (F3-M166) IP camera. It works fine on local IP address, but I can't access it over internet. This is what I have done step by step:

  1. I configured the local IP (camera_ip) and port (camera_port) of the camera, using the software from the vendor's website: http://p2.ipcam.hk/

  2. I opened http://**camera_ip**:camera_port and it works. The page asks me username and password, I login and I see the camera video output.

  3. On my router (Netgear dg834gt) I forwarded the camera port this way:

    • Service -> Add custom service
      • Name: camera1
      • Type: TCP/UDP (overkill)
      • port: camera_port
    • Apply
    • Firewall rules -> Inbound Services -> Add
      • Service: camera1
      • Action: allow always
      • Send to LAN Server: camera_ip
      • WAN users: any
    • Apply

  4. I have discovered my external IP (external_ip) address with http://www.whatismyip.com/

  5. Then I tried to browse the address: http://**external_ip**:camera_port.

Result: the connection times out and nothing happens. The external IP was not changed in the meantime. The router logs a lot of events like this one:

Wed, 2013-10-16 16:51:17 - TCP Packet - Source:**local_pc_ip**,2119 Destination:**external_ip**,*camera_port* - [camera1 rule match]

My question seems similar to #400855, but in my case not even the http forwarding is working.

14
  • 3
    Are you trying to go to http:/externalip:port from behind the router?
    – Dan
    Oct 16, 2013 at 17:07
  • 3
    Uh, yeah, its not going to work from the inside.
    – Dan
    Oct 16, 2013 at 17:13
  • 1
    For your information. There is NAT loopback technology which allows to connect to one's own public IP address from inside the network. Though, router should support it. (I state it here only because it was mentioned above)
    – VL-80
    Jan 5, 2014 at 0:10
  • 2
    Are you trying to connect to your external IP from inside your own LAN? If so, no wonder you are failing: that's called hairpinning and it is generally impossible for most routers, unless suitably configured (and this too can be done only on some routers). Oct 21, 2015 at 7:11
  • 1
    Although this question is old, it has been bumped to the front page. Although the OP has put that their question has been answered, they haven't put or recommended an answer that can be selected as the best answer...
    – Kinnectus
    Dec 7, 2018 at 12:08

0

Browse other questions tagged or ask your own question.