5

Every once in a while I seem to accidentally chord something that puts Windows 7 into "be a total PITA" keyboard mode. It seems to be some kind of special keyboard navigation or command mode, where single keypresses will make the UI do things, e.g., D toggles the active window between minimised and unminised. The mouse still works, but I can't use anything that needs text input anymore. This has happened while using several programs, including Minecraft and Firefox. I've been a Windows user for a long time, but I'm not familiar with this behaviour.

Since I have no idea how PITA Command Mode was activated, I don't know how to deactivate it either. Logging off the Windows user and logging back in returns things to normal and is my current solution, but I'd like to just completely disable this behaviour.

I at first assumed it was an accessibility option I'd left un-disabled, but I already have all the accessibility options turned off. I figured it was maybe a feature of my keyboard (MS Wireless Keyboard 3000 v2.0), but I have almost all of the special (media, etc.) keys turned off (in the up-to-date official drive management utility) and none of the ones still enabled jump out at me as possibly having this effect.

I have the Windows, Flip 3D, and Application keys disabled.

Language and keyboard are set to English (Canada) and US (a.k.a. "Qwerty"), respectively.

5
  • What keyboard layouts and language packs do you have installed?
    – Ramhound
    Oct 17 '13 at 1:35
  • @Ramhound US qwerty and en-us, en-ca I believe. I'll confirm and edit it into the question when I'm in front of the machine again. Thanks for the clarification comment! Oct 17 '13 at 1:59
  • 1
    All you asked was “What have I done?” and not “How do I fix it?”, so the following is not an answer to your question: When I experience things like this, I deliberately (i.e., slowly) go around the keyboard and press and release each meta key (i.e., both Shift keys, both Ctrl keys, Alt, Win, and Application). If something happens (e.g., a menu pops up), press the same key again until the something goes away. If that doesn’t work, try Esc. If this doesn’t fix your problem, try the ___ Lock keys, too, although they are less likely to help.
    – Scott
    Oct 17 '13 at 2:42
  • I've had a similar problem, and found a clumsy but effective way to recover. See superuser.com/a/765038/8986
    – Ira Baxter
    Jun 8 '14 at 10:45
  • On some of the earlier Microsoft wireless keyboards, I had an issue where if you were holding down modifier keys and pressing a sequence of other keys, it would eventually "forget" that you were still holding down the first key or so, completely changing the results. This happens a lot in some games. May 13 '15 at 13:25
13

I think the most likely scenario is that your Windows key is getting stuck “on.”

Certainly if Win+D is pressed, then it minimises windows, so if the Windows key is stuck, then D on its own would do this.

Usually just hitting the Win again should unstick it.

The other option is that you have Sticky Keys enabled, and you have "Lock modifier keys when pressed twice in a row" option enabled, and have then pressed the Win key twice to lock it.

You can enable sticky keys by hitting shift five times in a row, which is easier than it sounds (at least in my experience).

You can check the status of this by going to

 Control Panel\Ease of Access\Ease of Access Center\Set up Sticky Keys
11
  • That's why it is advised not to eat anything near the keyboard. I know, we are humans and sometimes we can't help it to happen. But what we surely can do is to periodically clean our workspace (including mouse and keyboard). Oct 17 '13 at 3:14
  • This sounds very, very likely because minimise/show desktop is exactly what D was doing, but I haven't yet been able to reproduce it deliberately using this theory. As I wrote, my Win key is disabled, so I can't think of how it's getting pressed, let alone stickied on. I could believe that the MS Mouse and Keyboard Center's key-disabling code isn't 100% effective and lets through a Win keystroke on occasion.... but I also have the shiftx5 shortcut off. But if the Win disabling is broken, then maybe it breaks in a way that makes it stay pressed... Oct 17 '13 at 17:30
  • @FranciscoAlvarado sometimes keys get "stuck" without being gunked up. Keyboards these days are better than in the past, but it's still possible. I've seen plenty of "stuck"-on-Alt keyboards over the years. Wireless keyboards just seem to be even more vulnerable to such issues.
    – Debra
    Oct 17 '13 at 17:49
  • You should copy more of my answers.
    – Josh
    Oct 17 '13 at 20:59
  • @Josh I'm pretty sure Paul could have independently written this, no copying necessary. StackExchange answers are often similar, with small variations in extra information or quality of presentation, and similarities aren't necessarily just thought-free copying. The extra information about how Sticky Keys could get enabled certainly enhances the usefulness of this answer, since I could then eliminate that possibility. Oct 19 '13 at 1:17
5
+50

What does the R key do when this happens? It sounds like your Windows key could just be a bit faulty?

  • Windows Logo: Start menu
  • Windows Logo+R: Run dialog box
  • Windows Logo+M: Minimize all
  • Shift+Windows Logo+M: Undo minimize all
  • Windows Logo+F1: Help
  • Windows Logo+E: Windows Explorer
  • Windows Logo+F: Find files or folders
  • Windows Logo+D: Minimizes all open windows and displays the desktop
  • Ctrl+Windows Logo+F: Find computer
  • Ctrl +Windows Logo+Tab: Moves focus from Start, to the Quick Launch toolbar, to the system tray (use Right Arrow or Left Arrow to move focus to items on the Quick Launch toolbar and the system tray)
  • Windows Logo+Tab: Cycle through taskbar buttons
  • Windows Logo+Break: System Properties dialog box
  • Application: Displays a shortcut menu for the selected item
2
  • I can't confirm right now because my keyboard is not currently possessed by evil spirits, but next time this will be a very handy reference sheet that I can test, and I've bookmarked this in a way I can get to it with just the mouse. Oct 17 '13 at 17:36
  • OK! My keyboard just pulled this stunt again, and I can confirm that these are what non-chorded keys are doing. How a Win key that's supposed to be disabled in the driver is "on" at all is still a mystery, but this helped. It doesn't get the checkmark, but I'll be giving it a bounty, thank you. Dec 21 '13 at 20:20
1

I had this happen to me inside Notepad++,

I pressed Ctrl+Alt+Del to bring up Task Manager, used keyboard shortcuts to highlight the Notepad++, then tab to End Process.

The enter key did not work, but space appeared to act as enter. When I ended the Notepad++ process, everything returned to normal.

1

Lenovo notebook, same issue, but none from the previous solutions worked, except for reboot.

Found by trying: quick swipe over Alt, Win, Fn, Ctrl reproduces this "error" (no h c v t keys), quick swipe over Ctrl, Fn, Win, Alt (opposite direction) brings all the keys back.

UPD: Shorter — Fn+Win or Alt+Win or Fn+Alt+Win are the keyboard shortcuts to get in and out of the state when keyboard is ignoring h c v t buttons.

1
  • 1
    Perhaps the same effect, but it's radically different keyboard hardware and that's going to confound the problem. One superficial disparity: I can't "swipe" those keys because of their physical shape, and the fn key doesn't exist near them. Feb 13 '16 at 19:05
1

For me the problem is Filter Keys turning itself on somehow. I don't remember if it's the same in Win7 but in Win10 it is located at Control Panel > Ease of Access > Keyboard > Filter Keys

1
0

This happens to me several times a day. I used to reboot each time, but now I just do Ctrl+Alt+Delete, then escape out of the menu that pops up and that's been working for me for over 2 weeks. Much faster than re-booting!

Still not sure why it keeps occurring, but as long as this little trick works, it's not that big a deal anymore.

-1

I think you might've activated the "F lock" key, as described here: http://support.microsoft.com/kb/894513

The F LOCK key switches between the standard commands that are labeled on the front of the keys, such as F1 or INSERT, and the alternate commands that may or may not be labeled on the keys.

Flock key

If that's the one, to turn off the behavior, er, just press the key to turn it off.

And thank you for the amusing post!

3
  • Definitely not F Lock. I have that disabled too, and as an extra precaution, I have all the function keys' "media" alternate personalities redefined to be macros to normal Fx keypresses so no matter what I do, F7 always sends F7 rather than its printed-on "Send Email" function. (Dear MS, why would I ever want that to happen with a single errant keystroke.) None of the observed behaviour matches the Fx defaults, anyway. Oct 17 '13 at 17:34
  • 1
    OK, others have suggested the Win key, seems most likely. But to be honest, the Wireless desktop 3000 set is relatively junky, in my experience; it's just not well made, and every one I've ever seen seems flaky at times (oh, maybe v2.0 is worlds better than v1). I'm still stunned that MS has a keyboard on which you can inadvertently press a key and then have other keys do things that are intentionally (?) NOT WRITTEN ANYWHERE ON THE KEY and not even well-documented. Don't hate me for saying this, but: also make sure that you have fresh batteries installed, stupid as that may sound.
    – Debra
    Oct 17 '13 at 17:43
  • Fresh batteries is good advice: I've seen it be flaky on a low charge before. I don't think that's the case here as it's otherwise behaving well and historically it hasn't needed a charge anytime soon after acting possessed. So far this keyboard and mouse have been pretty reliable (though I still miss my split Pro you have pictured above), but yeah, its plethora of special keys is annoying, and that's why I have them almost all disabled or set to "none" in the function list. Right now, I'm suspecting the utility software's disabling isn't disabling properly... Oct 17 '13 at 17:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.