0

This is a full IPSec tunnel provided by my university. I use this VPN at home and at public Wi-Fi cafés.

For some reason, I am not able to login to most websites while using the VPN at this specific public Wi-Fi. However, using the same VPN from home works without such drawbacks.

TLS/SSL seems to work fine in both cases (judging by the green https url), but it's logging into websites which does not work. Websites affected by this include for example twitter.com, superuser.com, ebay.com,...

  • 1
    We need more info for a diagnosis. When you are at a public cafe, can you log into your VPN? Once you logged into it, can you do something like ssh/Putty, or ftp? If you can do these things, can you ping the sites where you cannot login? If you load the web page whatismyipaddress.com, does the resulting IP belong to your university? – MariusMatutiae Oct 17 '13 at 14:49
  • I don't use ssh or ftp personally, but I'll make sure to try and connect my other OpenVPN service on the related ports. General surfing works without problems, just logging in doesn't. I also thought that the affected websites might block my IP address, but the IP and DNS that I use are both from my university (dnsleaktest.com) and should not be blocked ( because the university IPSec VPN works from home). – king_julien Oct 17 '13 at 18:43
  • @MariusMatutiae So, like I promised I have just tried to connect my OpenVPN service on the ports 20, 21, 22. While I can establish a connection and do general web surfing, logging in to said websites would still not work. Now, all of these were UDP connections. I configured the OpenVPN service to use TCP with port 80 as the gateway. Et voilà it works (logging in to all kinds of websites). This however is not the answer to my question as I actually wanted to get my university IPSec VPN to work 100% at the public Wi-Fi. – king_julien Oct 19 '13 at 9:19
  • Which OS are you on? – MariusMatutiae Oct 19 '13 at 10:24
  • @MariusMatutiae Ubuntu 12.04.3 64-bit. – king_julien Oct 19 '13 at 11:00
1

Yes, this is possible. Many public WIFi spots do not provide normal Internet access but instead only provide access to a small subset, such as HTTP[s] on ports 80 and 81. They fail when you want to use other services. Sometimes in surprising ways (e.g. when trying to parse everything though a transparent proxy).

| improve this answer | |
  • Thanks for the reply, I thought that https is only on port 443 and that therefore encrypted authentication should be possible on port 443. The ports 80 and 443 were definitely open e.g. my twitter client could update on port 443. The limitation that I have observed really seemed to be limited to the login only. I wish I could be more specific, but I'm not sure where and how to look. – king_julien Oct 17 '13 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.