12

Note that the answer accepted for this problem appears to only be applicable to systems using some form of full disk encryption.

I just tried to install windows 8.1 on my laptop, but it fails to install with the message:

Sorry we couldn't complete the update to Windows 8.1.
We restored your previous version of Windows to this PC
0xC1900101 - 0x20017

The update installed just fine on my desktop. The difference between the two machines is that the desktop has media center install, and isn't using TrueCrypt.

On the first reboot for the update, the laptop goes to the PC restore screen. Thus far I have just been selecting "Continue to windows 8."

Full WindowsUpdate.log http://pastebin.com/hGmAW4Q1

Update: Turns out it was TrueCrypt! I decrypted the drive, installed Windows 8.1, and then re-encrypted the drive and it worked just fine.

8
  • Could you post a screenshot of your system properties removing any personal information before you do so? Are you using full disk encryption by chance on the laptop?
    – Ramhound
    Oct 17, 2013 at 16:57
  • 1
    I googled something which sugested to browse to the C:\Windows directory and look for a file named WindowsUpdate.log. Search for the code "0xC1900101" to see if there is any indication of what the updater was doing at the time the code was logged.
    – horatio
    Oct 17, 2013 at 17:00
  • 1
    I am using full disk encryption, provided by TrueCrypt. According to Microsoft, TrueCrypt 7.1 is compatible with Windows 8.1.
    – cmorse
    Oct 17, 2013 at 17:01
  • 1
    you should decrypt the HDD before doing the update. Oct 17, 2013 at 17:34
  • 1
    @cmorse I decrypted my truecrypt encrypted boot-partition, updated to 8.1, and now I'm encrypting my boot partition again (I have multiple partitions, but only touched the boot/windows one)
    – flindeberg
    Oct 18, 2013 at 13:36

6 Answers 6

7

You should decrypt the HDD before doing the update. TrueCrypt is a 3rd party encryption and during setup Windows doesn't know how to handle it.

4
  • This was actually the case, it worked fine when decrypted. And now I'm encrypting again :)
    – flindeberg
    Oct 18, 2013 at 13:37
  • ok, nice to hear that it worked. Oct 18, 2013 at 17:11
  • Alright, sounds like I don't have much of a choice...honestly, it seems odd. I've installed windows service packs many times with full disk encryption enabled with no problems. I'll try decrypting and then doing the update tonight.
    – cmorse
    Oct 18, 2013 at 19:25
  • I hope you read my answer below before you (potentially) waste your time. Decryption may be necessary, but it would be a shame if the installation still fails, and it just might. Oct 18, 2013 at 20:27
6

I'm concerned that the answers provided here are going to lull the original poster, and others who may read this post, into a false sense of confidence that decryption is a slam dunk solution.

It's not. My installation failed with exactly the same error code; however, I do not use encryption. Larry Magid had the same error, and he does not mention encryption. Google searches turn up a number of instances of this exact error, many of which do not involve encryption.

In my view, the evidence is clear that the upgrade package is significantly flawed, and we need Microsoft to issue an updated version that corrects this.

The best answer, in my view, to this problem is: wait a week or two. And in the meanwhile, please consider submitting a bug report to encourage them to hurry.

5
  • 2
    I wish that Larry Magid had been more specific about what exactly Microsoft support did to fix it! But it does seem that decrypting solves the problem for a lot of people, so, it is worth a shot if you do have full disk encryption enabled.
    – cmorse
    Oct 19, 2013 at 18:01
  • 1
    Agreed. I am glad that encryption was the sole issue for you. But it looks like the error code we are seeing is a "catch all" for every issue the MS did not specifically anticipate. Oct 19, 2013 at 22:50
  • That would explain the number of views that this question has been getting.
    – cmorse
    Oct 20, 2013 at 18:00
  • I disabled/removed a few devices I don't use anymore before the upgrade to Windows 8.1. Especially Western Digital's WD SES Device driver, which seemed to be causing the issues for me. The upgrade ran smoothly the second time.
    – Vinayak
    Jun 4, 2014 at 6:53
  • This is relevant again. I am getting 0xc1900107 when a Windows 10 update fails
    – mmesser314
    Feb 1, 2018 at 14:53
1

I'm using WinMagic SecureDoc (6.1 x64) and my update failed as well with the same error. This may be indeed something connected to encryption.

As Win 8.1 is supposed to have a built-in auto-encryption there may be some conflict...

0

Yepp, it is the encryption indeed. Not TrueCrypt only. BitLocker and I think that any kind of an encryption sw will cause this. It does not really matter whether the sw is or is not compatible with Windows 8.1. The 8.1 update runs fine after the HD is decrypted.

0

There is no choice, you must decrypt the drive before the upgrade.

-2

Yes Just Decrypt the Disk or Volume! I used PGP and after decryption updated fine!

1
  • 2
    Did you get the 0xc1900101-0x20017 error when the disk was encrypted? Was it the boot-partition?
    – flindeberg
    Oct 18, 2013 at 11:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.