0

I'm running into an issue where Java will not launch in IE 9.

Specifically IE 9.0.8.112.16421 Update Version 9.0.21

I am upgrading from version 1.6, i uninstalled version 1.6 then i installed 1.7.0_45.

When I go to a webpage i have confirmed that Java will not start, instead i receive an X where the java applet should be. Similar to if i did not have Java installed.

I checked my addons in IE and my Java ones are enabled.

When i check event viewer, this is what i see:

Faulting application name: javaw.exe, version: 7.0.450.18, time stamp: 0x525404d7
Faulting module name: msvcr100.dll, version: 10.0.40219.1, time stamp: 0x4d5f0c22
Exception code: 0xc0000417
Fault offset: 0x0008af3e
Faulting process id: 0x13e4
Faulting application start time: 0x01cecb5ab13d3371
Faulting application path: C:\Program Files (x86)\Java\jre7\bin\javaw.exe
Faulting module path: C:\Program Files (x86)\Java\jre7\bin\msvcr100.dll

I went to the Microsoft web site, and a forum indicated I needed to install Microsoft Visual C++ 2010 Redistributable Package (x86) to get the dll. I did this, but I still get the same error.

I also tried copying the dll from a working system, that did not work either.

Any advice would be much appreciated.

Thanks Paul

  • Did you install all updates connected to the Microsoft Visual C++ 2010 Redistributable Package there is a Service Pack you should also install. I would use singularlabs.com/software/javara and see if it helps at all. – Ramhound Oct 17 '13 at 17:58
  • @Ramhound I installed both the x84 and x64 Microsoft Visual C++ 2010 Service Pack 1 Redistributable. no luck. I also used the JAVARA uninstaller, it removed all the components of java but after reinstalling it did not work. – Paul Mung Oct 17 '13 at 19:08
  • I assume you have tried a system restart? Those files are also located in your Windows folder I would try copying the 32-bit version located there. – Ramhound Oct 17 '13 at 19:15
  • @Ramhound Tried restarting. Are you saying copy the dll from system32 to the java folder? – Paul Mung Oct 18 '13 at 20:30
  • No. That would be the 64-bit dll. You want to replace the dll located in the SysWOW64 folder. – Ramhound Oct 19 '13 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.