4

I saw your answer to a question which has somewhat similar details like mine in this thread: Recovering a Partially Formatted USB Thumb Drive. However, in my case, my usb is write- protected. Can you help me with it?

enter image description here

As you can see, there is a part in the picture above saying, Current Read-only State: Yes, and I think it's because my USB is write- protected. I tried entering a command, attributes disk clear readonly, and it replied Disk attributes cleared successfully.. Ensuring that I can format the USB now since the write- protection is gone, I entered, detail disk, but it only gave me the same results.

enter image description here

Even though it gave the same results, I continued following your solution. I entered, FORMAT RECOMMENDED OVERRIDE, but still, it gave me a reply saying The media is write protected. Seeing this result, I did not continue the following solutions, thinking it would just worsen the state of my USB and I would just obtain the same results. What can I do? Also, I still want my USB file system to be FAT32.

enter image description here

Here is the view of my USB drive in My Computer when I mounted it.

In addition, my USB doesn't have a switch.

My question with complete details is here, since I can't post more than 2 links and I can't upload images: http://swampertblaziken.wordpress.com/2013/10/18/how-to-make-a-write-protected-usb-drive-usable-using-diskpart/

5
  • I've had a similar problem, and all I can say is your drive may be permanently lost, except maybe a firmware flash. You could open it and check what controller chip it uses to try and find a flashing tool. Do you know the events leading up to this?
    – Bob
    Oct 22, 2013 at 12:01
  • As much as possible, I will not resort to "hard" methods. But, if I think that, it's the only way, then I'll consider this. Anyway, thanks for your suggestions!
    – Acnologia
    Oct 24, 2013 at 17:14
  • 1
    i solved this...i used Novicorp WinToFlash, and selected erase disk
    – user319594
    May 1, 2014 at 0:06
  • having the exact same problem. i create a media on usb drive with microsoft tool to install win10. Now I want to recover my usb drive. But cannot clear the write protection. Oct 10, 2021 at 13:39

4 Answers 4

3

I've resolved the same problem on by USB 3.0 disk with a tool from Apacer.

Get on http://us.apacer.com/support/download/result/3,8,0,

Donwload "USB3.0 Repair tool", unzip and launch Restore.exe.

Click on "Restore" button, follow screen instructions.

Source : http://www.makeuseof.com/tag/format-write-protected-usb-flash-drive/

0
1

Try the following.

  1. Open a command window by running the diskpart command from a Command Prompt.
  2. Type list disk.
  3. Select the disk you are going to modify. Example select disk 1.
  4. Clear the Read-Only attribute on the selected disk: attributes disk clear readonly.
  5. When you are done modifying the disk attributes just issue the exit command.

This video can help you too.

2
  • Sorry sir, but as I have mentioned on the description of my question, I have already tried that step. It replied that my usb is in read- only state.
    – Acnologia
    Oct 22, 2013 at 11:32
  • Still same for me too. Cannot clear the read only state Oct 10, 2021 at 13:40
1

If the current read only state keep showing yes and read only keep showing no after going through diskpart, use USB 3.0 Repair Tool and select restore. It fix mine. Few things to keep in mind before performing the restore:

  1. Back up your content to other place. (Restore will wipe the data in the USB drive).

  2. Make sure no other USB drive or removable drive is plug in the same computer. (For Restore, it does not give you the chance to indicate which drive to perform the restore task).

0

It is possible to manufacture USB sticks which contain permanently read-only partitions. This is usually done for advertising purposes, you place your brochures on a stick and give it to potential customers. In these cases the hardware won't let you reformat it or delete the data. Do you have such a USB stick?

1
  • What is a USB stick? Also, I think my USB is not manufactured the way you think it was, since I can freely format it before. In addition, my USB was also write- protected before, but I solved it by using the registry editor method. Anyway, thanks for your suggestions!
    – Acnologia
    Oct 24, 2013 at 17:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.