0

No matter what I do, Eclipse keeps saying that "Eclipse is running under 1.6, but this Java project has a 1.7 Java compliance level, so WindowBuilder will not be able to load classes from this project. Ues a lower level of Java for the project, or run Eclipse using a newer Java version."

I spent two hours on this, so before I throw everything out, I thought I should ask you guys.
The system is an iMac with a 10.8.5 OS X.
Installed JDK 7 from Oracle. (java -version shows the version as 7.)
If I print it with Java, it prints 7.

Modified Eclipse settings (Compiler) to 7.
Used override in project settings to make it 7.
Modified eclipse.ini file so the -vm points to 7.

I'm out of ideas and patience. Both.

Update #1: System Preferences shows Java 7 as well.

3
  • What is your JAVA_HOME set to?
    – Avis
    Oct 19 '13 at 3:58
  • To the new JDK. In the end I spent another few hours to install / remove eclipse workspaces, import project, install plugins and blah blah. In the end I made it work by launching the latest install from cli. But again, I don't know what worked.
    – Apache
    Oct 19 '13 at 11:21
  • Which Eclipse are you use? Helios, Juno or Kepler?
    – herry
    Dec 19 '13 at 6:43
0

I had this exact problem. Below is how I solved it.

It looks like more work than it really is. If I accidentally deleted a step trying to format all this text, let me know.

First, on your Mac, you should find the "default Java from Apple" residing at: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java

From the Eclipse menu: Eclipse> Preferences> Java> Installed JRE's>

  • CLICK "Add.."
  • SELECT "Mac OS X VM"
  • CLICK "Next.."

In the 'JRE Definition dialog' that comes up,

  • SELECT "Directory.." next to JRE Home,
  • DRILL DOWN and SELECT /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/.

Finish filling out what is needed, and then,

  • SELECT java 1.6 in Eclipse> Preferences> Java> Installed JRE's>
  • SELECT Eclipse> Preferences> Java> Installed JRE's> Execution Environment>.
  • CLICK on "JavaSE-1.6", and make sure that your Java 1.6 Runtime you just set up is checked.

RIGHT CLICK on your project folder in the workbench to open your projects properties, and double-check that Java 1.6 is good to go under the "Java Compiler" menu and sub-menu's.

While still in your project's properties dialog:

  • CLICK "Run/Debug Settings"
  • SELECT your project's name,
  • CLICK "Edit.."

In the resulting dialog, 'Edit launch configuration properties':

  • CLICK the "JRE" tab and ensure it's Java 1.6
  • SELECT the "Classpath" tab and double check that it also is including Java 1.6

In the 'Project Explorer' tab, within your project, find the "JRE System Library" amongst your project's folders. Make sure it say's Java 1.6

if NOT:

  • RIGHT CLICK it
  • SELECT "Properties"
  • CHECK MARK "Execution Environment", and in the drop down menu, SELECT JavaSE-1.6

RE-START eclipse

I'll confess, it is late and I'm hurrying, so changing every reference from 1.7 to 1.6 I have it working as I write this. In fact, I JUST got it working, so am sharing this before I get at it!

The BELOW step I also did. In my case, I was running Indigo 3.7 on Mac Mavericks. If the above still isn't working, this is the other thing I added in my situation.

  • RIGHT CLICK your actual Eclipse icon
  • SELECT the "Show Contents" menu item.
  • OPEN the "Contents/" folder
  • OPEN the "MacOS/" folder
  • OPEN "eclipse.ini" in a text editor.
  • ABOVE the line that says "-vm" (without the quotes)
  • ADD the line: -vm /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java

This starts eclipse with Java 1.6, rather than the Java 1.7 that is now default on your system. Obviously, you need to re-start eclipse after editing it's .ini file.

0

Simple steps
step-1 go to the eclipse window--> preference-->java--> compiler (serach java) we can get the compilercompliance level as let say 1.7

step-2 chek the java version in the command prompt

$ java -version get the below message java version "1.6.0_35" OpenJDK Runtime Environment (IcedTea6 1.13.7) (6b35-1.13.7-1ubuntu0.12.04.2) OpenJDK Server VM (build 23.25-b01, mixed mode)

so u can see the java version is mismatch

so open the eclipse.ini from the folder exist in the eclipse installable folder/

append the jdk version -vm /usr/lib/jvm/java-7-openjdk-i386/bin/java

-startup plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar --launcher.library plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.200.v20140116-2212 -product org.eclipse.epp.package.standard.product --launcher.defaultAction openFile -showsplash org.eclipse.platform --launcher.XXMaxPermSize 256m --launcher.defaultAction openFile --launcher.appendVmargs -vm /usr/lib/jvm/java-7-openjdk-i386/bin/java -vmargs -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=256m -Xms40m -Xmx512m

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.