I tried to install Windows 8.1 from the Windows Store and got the error 0x80070002. It seems that this error means that the download was not completed.

  • I tried to restart the installation
  • I tried to clear the windows store cache
  • I tried to delete every thing in the C:\Windows\SoftwareDistribution\Download folder
  • I tried to do a clean boot

It always fails with the same error.

As a workaround, is there a way to download windows 8.1 from somewhere else than the windows store?

  • 3
    You have to have a MSDN Subscription to download the ISO files. Other than this, you will need to obtain a retail copy of Windows. The Windows Store is typically the only way to upgrade for most users.
    – kobaltz
    Oct 18, 2013 at 16:07
  • Which is not very practical when the Windows Store fails. Oct 18, 2013 at 16:26
  • @cmoibenlepro - Between the answers superuser.com/questions/661261/… and superuser.com/questions/650019/… you are able to get the .iso from Microsoft, burn it, then install it.
    – Ramhound
    Oct 18, 2013 at 16:51
  • I read those 2 threads, but I can't download an .iso since I do not have a MSDN subscription. Oct 18, 2013 at 19:04
  • 1
    Do you have multi-bootable partitions? If yes, mark your Windows partition as "Active". That did the trick for me...
    – user265143
    Oct 20, 2013 at 0:42

3 Answers 3


Do you have multi-bootable partitions? If yes, mark your Windows partition as "Active". That did the trick for me... – rlyeh

after trying several solutions found on the web (deleting dowload folders, desactivating antivirus...), The solution above just worked fine. Not even necessary to reboot. Thanks


Agafous's solution was spot on. It seems to be that in Windows 8.1 upgrades, it freaks out if you have your primary hard disk partitioned in such a way that your primary boot partition isn't necessarily your first partition on the disk - this is the case with large vendor desktop PC's from the likes of HP and Dell who tend to have 'recovery' partitions on the disk.

I ran into this same problem on my Dell E9900SF desktop PC but didn't have an issue whatsoever on my ASUS laptop. I found this page and the solution worked.

If you want to know how to make a partition active, here is a write-up on how to do it in Vista: http://windows.microsoft.com/en-au/windows-vista/mark-a-partition-as-active

Win 8 is very similar - go to Control Panel\All Control Panel Items\Administrative Tools and select "Computer Management" to find where you need to be, then follow the instructions from the link above from there. You'll be fine.


There's a folder C:\$Windows.~BT where the update is downloaded. Deleting this folder lets you start the download process again in the windows store.

Update 1: it lets you download the update again, but the installation still doesn't work.

Update 2: from the setuperr.log in C:\$Windows.~BT\Sources\Panther

SetupMgr: Error reading Store SQM registry data. Data = [StoreSetupDownloadPause], HRESULT = [0x80070002]    
SPGetCurrentOSGuid: BCD Open failed. Error: 0x00000002[gle=0x00000002]
Cannot get the current OS GUID. Error: 0x80070002[gle=0x00000002]
CSetupPlatform::ResurrectNewSystem: Failure: Win32Exception: 
\\?\C:\$Windows.~BT\Sources\newsystem.dat: The system cannot find the file specified. 
[0x00000002] __cdecl UnBCL::FileStream::FileStream(const class UnBCL::String *,enum UnBCL::FileMode,enum UnBCL::FileAccess,enum UnBCL::FileShare,unsigned long)[gle=0x00000002]
  • Tried that, the download restart, but the installation still fails with same error 80070002. Oct 19, 2013 at 16:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .