I'm trying to connect to a samba share using windows XP Professional. I type \\mother\home into My Computer's address bar, and as expected a "Connect to mother" dialog appears for me to type in my username and password for samba running on \\mother.

The samba instance on \\mother is Samba v4.0.10 configured as an active directory with domain HOME (realm home.something.net). So I type in my username and password:

enter image description here

As soon as I click ok, The same box reappears no different from before, except that the password is cleared.

What's weird is that if I run net use H: \\mother\home /user:HOME\matt, the output is this:

The password or user name is invalid for \\mother\home.

Enter the password for 'HOME\matt' to connect to 'mother': {types password}
The command completed successfully.

What steps can I take to debug this issue?

  • The windows XP machine has a local user account with a different password. Could this be an issue, even if I am explicitly logging in as HOME\matt and not LOCALPC\matt? – Matthew Sainsbury Oct 18 '13 at 16:28
  • is your samba configured to only allow up-level (NTLMv2) connections? if so, you can either reduce the security for samba, or in your local security policy (on xp, secpol.msc) you can tell it to use more stringent encryption. imss.caltech.edu/node/396 – Frank Thomas Oct 18 '13 at 16:35
  • thanks for posting. To be honest I am an utter noob with active directory, so your comment taught me about different authentication levels. I have since solved the problem by simply rebooting the machine. What tools should I be using to figure out these and other problems with active directory? – Matthew Sainsbury Oct 18 '13 at 16:52
  • I'd offer some options if I could. I just know this hack from dealing with many different types of clients for samba. – Frank Thomas Oct 18 '13 at 18:18

The Windows machine must have been caching something vital, because rebooting the machine fixed the problem. It seems many authentication problems can be solved by something as simple as a reboot, so maybe it's a good idea to try this before messing with the active directory and potentially breaking it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.