In Windows 7, after a few weeks of running Hamachi VPN, the internet icon in the system tray shows a red "X", indicating I have no network connection:

enter image description here

This is false, as I am not only connected to two networks, I'm also connected to the internet (as shown below), therefore, the icon should show no errors.

enter image description here

I've researched the LogMeIn Hamachi help forums and several other related forums and no one seems to have posted a working solution.

What I've Tried So Far:

  • I have uninstalled Hamachi

  • I reset the local LAN adapter.

  • I have changed the order of listed connections in Network Connections > Advanced > Adapters & Bindings

  • I have disabled IPv6 on both networks, and one at a time

  • I deleted the "Incoming Connection" I had for my Windows 7 VPN in Network Adapters

I've run my research resources dry and I'm out of ideas. Any suggestions?

  • 1
    Have you tried Resetting (enabling/disabling) the main adapter through Change adapter settings?
    – Yass
    Commented Oct 18, 2013 at 20:09
  • @Yassar Yes, no change. I added that to my question.
    – user201262
    Commented Oct 18, 2013 at 20:15

6 Answers 6


At first, I thought this didn't work, so I moved on, but it turns out I didn't allow enough time for it to work:

I followed the instructions in the high rated answer in this thread.

  1. Click Start, [click Run], type regedit, and then press ENTER.

  2. Locate and then click the following registry subkey:

  3. Right-click this subkey, click Export , and then save the selected branch in a file.

  4. Click the Network subkey again, and then delete the Config entry. Do not delete the >Network subkey. The Config entry will be reconstructed when you restart the computer.

  5. Restart the computer. You may have to manually turn off the computer.

  6. The config key is re-created on the next boot up.

The final step (6) takes a few minutes to complete. During that time, I unplugged my network cable and replugged to initate the internet connection and the key rebuild.

  • This seems very weird. Accessing registry for this? Is there no other way? Why would this possibly work? I understand the export (backup up a copy before destroying).
    – ejbytes
    Commented Jul 20, 2019 at 22:35
  • Config entry got recreated but did not change the icon. I still see red X on network connection. Commented Dec 30, 2020 at 6:48

Lets try flushing DNS cache and renewing your IP.

Flush the DNS cache and restore MS's Hosts file ... Copy and paste these lines in Note pad.

@Echo on
attrib -h -s -r hosts
echo localhost>HOSTS
attrib +r +h +s hosts
ipconfig /release
ipconfig /renew
ipconfig /flushdns
netsh winsock reset all
netsh int ip reset all
shutdown -r -t 1
del %0

Save as flush.bat to your desktop. Right click on the flush.bat file to run it as Administrator.

Your computer will reboot itself.

this solved my issue.

  • 1
    The 3 ipconfig commands worked for me (release, renew, flushdns).
    – firedfly
    Commented Jan 6, 2015 at 17:05

If you are able to verify that you are connected to the internet, the icon should have no bearing on anything. However, I can understand how it is tough to look at. Try opening a command prompt as an admin and typing:

c:\ipconfig /release

c:\ipconfig /renew

c:\ipconfig /flushdns

c:\ipconfig /registerdns

See if any of these help.

  • I agree with the first bit, it was more of an annoyance. Thanks for the tip, though I've solved the problem.
    – user201262
    Commented Oct 18, 2013 at 20:34
  • This worked for me when I got hung up (actually the /release did the trick). I checked out what Moses did in the hopes of a permanent cure, since this happens once every few days to me.... hmm, his answer doesn't seem relevant, since I'm running of a virgin (well, no, but not upgraded from Vista) Win7 system with no hardware upgrades.
    – Ira Baxter
    Commented Jun 11, 2015 at 6:52

From the Control Panel:

  1. Go to Device Manager
  2. Expand the Network Adapters section
  3. For each device, right-click/uninstall the adapters.

Restart when all done.


I experienced the same problem without any VPN set up. What solved it was to make sure the Network Connections service was running.

To enable the service, press the Win key, they start typing "Service". Go to Services, find Network Connections (click on the Name column to sort), right click, Properties, and choose Startup Type to Manual. Start the service, and the icon should change to the Wireless settings one.

enter image description here

I had disabled the service in an attempt to reduce the number of processes running on the system, and it didn't seem to cause any problem other than the icon looking like a network cable, instead of the wireless signal bars.

  • Mine: same as image, all okay. I still have an X on my LAN tray-icon too. It really bugs me because I have internet, but sometimes my "network connection" reads "not connected", but I still have access to the internet, but my applications don't. E.g. my browser allows me to access the web, but my Outlook will not. Sometimes I disable LAN, then enable it and the X disappears. Sometimes I have the X and all is good. All my services are disabled, except for LAN. I prefer LAN over Wi-Fi. So I have to check my status, rather than just look at the tray-icon which reveals nothing about status.
    – ejbytes
    Commented Jul 20, 2019 at 22:31

This happens whenever you set up a new incoming connection.

It happened to me a while back and I was unable to find a solution apart from going to 'Network Connections' and deleting the incoming connection.

I think it's just a glitch within Windows.

  • I did have a VPN set up, and deleted it, but it didn't solve the problem.
    – user201262
    Commented Oct 18, 2013 at 20:17

You must log in to answer this question.