Yesterday, I updated my computer from Windows 8 to 8.1. I have VMWare Workstation 10 running Windows XP on this computer and prior to the update I had no issues connecting to my network. However, since updating, I haven't been able to connect to any network and I'm getting the following error:

The network bridge on device VMnet0 is not running. The firtual machine will not be able to communicate with the host or with other machines on your network.

Failed to connect virtual device Ethernet0

I've checked all of my settings which currently have my network adapter set for a bridged connection and under device status "connected" is checked.

Not really sure where to go from here, but after doing some research I have seen that others users have reported getting this error when updating the OS (any OS, not windows 8 specifically) of the host computer.

  • Repair vmware workstaion. Go to Program & Features, select vmware and click repair. – magicandre1981 Oct 19 '13 at 5:52
  • The same when upgrading to Windows 10 1511. Answer from Saravana Ganesh worked perfectly! – Al Bundy Nov 17 '15 at 12:18

I did the repair (not from Program install/change but using original install file).

Once Repair was complete, I powered up guest system. After a couple of minutes, I got 'Set network connection' pop-up without clicking on anything, I selected Home network, it asked me what I would want to share - I checked/selected everything, it then came back with a password for the homegroup which I saved, in case I need it. That's it. My internet access came back. I did the same procedure for all 4 of my guest systems and restored by internet in them.

BTW, I already had VMWARE bridge protocol on my Host's network adapter and my guest OS had it on automatic - So I did not tweak anything there, but it did not fix my internet issue. So I followed the repair route as somebody had suggested here.

  • Hey thanks for the tip, that worked perfectly. I'm up and running again! – wrigley06 Oct 21 '13 at 15:36
  • Thanks. Worked for me too. (VMware Player version: 6.0.1 build-1379776) – Oq. Dec 11 '13 at 10:48
  • 1
    This worked for me. BTW: I did not have the "Virtual Network Editor". – PiTheNumber Jun 21 '17 at 12:05

You can fix it right from your VMware workstation.

  1. Go to the Edit menu
  2. Select Virtual Network Editor
  3. Select "Restore Default"

It will take a few minutes but after that it will work fine.

  • 17
    This is the best answer – user2909913 Nov 23 '14 at 7:47
  • 4
    This answer looked like it provided the simplest solution, so I tried this one first. Worked perfectly to restore VMware's network access after upgrading from Windows 7 to Windows 10. I had never used the Virtual Network Editor before, so my settings were never changed from the defaults. Still, restoring the defaults restored the network functionality. – Jan Goyvaerts Sep 18 '15 at 2:10
  • 3
    Perfect answer. – Riz Jan 12 '16 at 12:28
  • 4
    Worked in my case to restore VMware network after installing the Windows 10 Anniversary Update. – Alex Che Aug 4 '16 at 13:56
  • 4
    Yes, same here: Worked to to restore VMware network after installing the Windows 10 Anniversary Update. – Matthew Watson Aug 19 '16 at 8:59

What I discovered is the VMware Bridge Protocol had been removed during my upgrade to 8.1 and has to be re-installed:

On Windows host machines, reinstall the VMware Bridge Protocol:

In Windows Vista/7

  • Click Start → Control Panel → Network and Internet → View Network status and tasks → Change adapter settings.
  • Right-click any network adapter icon and click Properties.
  • Select VMware Bridge Protocol and click Uninstall.
  • Click Install.
  • Select Service and click Add.
  • Select VMware Bridge Protocol and click OK.

Those instructions ask you to uninstall the VMware Bridge Protocol, but in my case, the Bridge Protocol wasn't there to install. However, when I installed it and checked the protocol box, and then chose bridged connection on my VM I was able to connect to the internet again.

I also turned on network sharing for the VMware virtual nics within Windows.

  • 2
    VMware is the worst. It is so brittle. It breaks seemingly at random. And most of the error messages provide no help whatsoever. – Jonathan Wood Jan 18 '16 at 20:33
  • This works after upgrade Win7->Win10 using the Player if you do not have the network editor – Geert Apr 20 '16 at 14:00

After upgrading to 8.1, I found the quickest fix was to "Restore Default" in the Virtual Network Editor.

After that completed, I was able to select VMware Bridge Protocol under the VM Network Adapter's properties.


I also had the same problem after upgrading from Windows 8 to 8.1, I found that reinstalling WorkStation 10 and selecting the repair system option resolved my problems.

  • Hey Jarek, your answer was similar to the one above, but I just wanted to let you know that that worked. Thanks – wrigley06 Oct 21 '13 at 15:36

Had the same issue with Windows 2012 to Windows 2012 R2. But be careful - I tried removing the VM Bridge Protocol only to find out I could not install it again. When trying to add the protocol back it was not listed.

However, the Repair seems to have done the trick. You can tell the issue (in Workstation 10 at least) under Edit > Virtual Network Editor... - once there, you will see that VMNet0 is indeed not listed. It is apparently there but something different in the settings.

Running the repair from the original EXE did correct it and when viewing, the VMNet0 set to Auto-Bridged reappeared.


None of the other answers worked. I even tried upgrading from Workstation 8 to Workstation 10, without getting guest network connectivity back.

In the end, I had to do an explicit uninstallation of VMware and uncheck the "Save configuration settings" checkbox. Once I reinstalled from scratch, the network connections were back.

protected by Community Jan 12 '14 at 6:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.