2

I have just upgraded to Windows 8.1, and after the upgrade process is finished, I can't connect to internet.

I tried running the "Troubleshoot problems":

Troubleshoot problems

It concluded that DHCP needs to be activated:

must activate DHCP

I let it activate DHCP, and I got internet connection back.

The problem is I want to set this PC to a certain IP address (the IP address that it has been using all this time).

I am also using Hyper-V, which I suspect has something to do with this problem.

After I regained internet connection, I tried running one of my Hyper-V VM. From inside the VM I can connect to internet. That VM has static IP address.

I also noticed that in "Control Panel\Network and Internet\Network Connections", I usually have a network connection called vEthernet (Realtek PCIe GBE Family Controller Virtual Switch). I didn't find it there after upgrade.

How do I set my PC to a static IP while retaining internet access in Windows 8.1?

EDIT

I have managed to recreate vEthernet (Realtek PCIe GBE Family Controller Virtual Switch) by unchecking Allow management operating system to share this network adapter in Hyper-V's Virtual Switch Manager and then checking it again.

host virtual adapter

But when I changed the adapter to use static IP, it still can't connect to internet.

  • Are you able to ping IP addresses? For example 64.4.11.37 (microsoft.com). If yes, this would suggest it's just a DNS problem but TCP/IP works otherwise OK. – Nikos C. Oct 19 '13 at 1:51
  • @NikosC. with static IP ping failed with PING: transmit failed. General failure.. – Endy Tjahjono Oct 19 '13 at 1:57
  • Can you please open powershell and do the command Get-NetAdapter -Name * | fl and then copy and paste the text it outputs as a edit to your question? – Scott Chamberlain Oct 19 '13 at 7:58
  • @ScottChamberlain I have included Get-NetAdapter -Name result. – Endy Tjahjono Oct 19 '13 at 8:22
  • 1
    That was the wrong command, I was trying to do it from memory, I don't have my server 2012 box in front of me to test it. The command I was looking for is the one that shows the IP/gateway/dns information. I know it's pattern is Get-Net******* I just can't remember what the ****** is. My money is on the default gateway is not getting set up when you do the static setup. That or DNS, but the ping command would have worked when you pinged a IP if it was DNS. – Scott Chamberlain Oct 19 '13 at 8:33
2

Check that your default gateway is set for your static IP configuration. From your symptoms it sounds like that is most likely your problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.