0

My laptop is Dell inspiron R15. It comes with Windows 8 64bit, Chinese Home Edition. I later upgraded to Windows 8 64bit, English Pro. Edition. Then I installed Linux and setup dual-bool. Now, I can see the Windows 8.1 update in the Windows Store. I have 8GB memory installed, and about 90GB free disks pace. My nVidia driver is up to date.

Here is my update log. Some people say the failure is caused by conflicts, and the log can tell you. But I could not find anything useful to help me locate the conflicts, if any.

fail

Couldn't update to Windows 8.1

Sorry, we couldn't complete the update to Windows 8.1. We've restored your previous version of Windows to this PC.

0xC1900101 - 0x20017

  • Have you installed all available updates and what method are you using to install the update? I would also remove any USB devices not required to use your system. This will remove the possibility its an USB Device driver problem. – Ramhound Oct 19 '13 at 6:18
  • I always install the Windows from the Windows Update center...is there any other choice? And sure I have ran update several times to make sure I have installed all updates available. – David S. Oct 19 '13 at 6:20
  • Windows 8.1 isn't installed through Windows Update though. There are two methods, the first is through the Windows Store, the second is through the use of an .iso. – Ramhound Oct 19 '13 at 6:22
  • Are you using truecrypt as per the possible duplicate question? – Tog Oct 19 '13 at 13:06
2

Like M$ did many times in the past, its error message always lead you to the wrong direction. In my case, the error has nothing to do with my original Windows settings, or application I have installed. It is about how my system is booted.

My system has dual-boot, installed by grub2. So the MBR of my HDD is certainly not M$ style. I find my old Windows 8 installation media, a USB key. Boot my laptop from the key, then:

  • Choose Repair
  • Then Advanced
  • Then Prompt
  • Do this magic:

    bootrec /fixmbr

  • Reboot

After that, retry install the update from Windows Store. And everything worked fine.

I am still playing with this new system, and have not tried to restore grub2...cross fingers :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.