0

I am always getting the following error in Posh-Git in Powershell, in ConEmu on Windows 7 64-bit:

Resolve-Path : Cannot find path 'C:\wamp\www\MobileApps\Backbone\%HOMEPATH%' because it
does not exist.
At D:\Users\Andy\Documents\WindowsPowerShell\Modules\posh-git\GitUtils.ps1:265 char:13
+     $home = Resolve-Path (Invoke-NullCoalescing $Env:HOME ~)
+             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (C:\wamp\www\Mob...bone\%HOMEPATH%:String)
   [Resolve-Path], ItemNotFoundException
    + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.ResolvePathComma
   nd

Join-Path : Cannot bind argument to parameter 'Path' because it is null.
At D:\Users\Andy\Documents\WindowsPowerShell\Modules\posh-git\GitUtils.ps1:266 char:29
+     Resolve-Path (Join-Path $home ".ssh\$File") -ErrorAction SilentlyContinue 2> ...
+                             ~~~~~
    + CategoryInfo          : InvalidData: (:) [Join-Path], ParameterBindingValidationExc
   eption
    + FullyQualifiedErrorId : ParameterArgumentValidationErrorNullNotAllowed,Microsoft.Po
   werShell.Commands.JoinPathCommand

Can anybody advise what might be wrong?

EDIT: Add settings XML

<?xml version="1.0" encoding="utf-8"?>
<key name="Software">
    <key name="ConEmu">
        <key name=".Vanilla" modified="2013-10-19 18:24:13" build="131017">
            ...
                <key name="Tasks" modified="2013-10-19 18:24:14" build="131017">
                <value name="Count" type="dword" data="00000003"/>
                        <key name="Task1" modified="2013-10-19 18:24:14" build="131017">
                    <value name="Name" type="string" data="{cmd}"/>
                    <value name="GuiArgs" type="string" data=""/>
                    <value name="Cmd1" type="string" data="cmd.exe &quot;-new_console:d:%userprofile%&quot;"/>
                    <value name="Active" type="dword" data="00000000"/>
                    <value name="Count" type="dword" data="00000001"/>
                </key>
                        <key name="Task2" modified="2013-10-19 18:24:14" build="131017">
                    <value name="Name" type="string" data="{Git Bash}"/>
                    <value name="GuiArgs" type="string" data=""/>
                    <value name="Cmd1" type="string" data="&quot;C:\Program Files (x86)\Git\bin\sh.exe&quot; --login -i"/>
                    <value name="Active" type="dword" data="00000000"/>
                    <value name="Count" type="dword" data="00000001"/>
                </key>
                        <key name="Task3" modified="2013-10-19 18:24:14" build="131017">
                    <value name="Name" type="string" data="{Powershell 3}"/>
                    <value name="GuiArgs" type="string" data="/icon &quot;%SystemRoot%\syswow64\WindowsPowerShell\v1.0\powershell.exe&quot;"/>
                    <value name="Cmd1" type="string" data="%SystemRoot%\syswow64\WindowsPowerShell\v1.0\powershell.exe"/>
                    <value name="Active" type="dword" data="00000000"/>
                    <value name="Count" type="dword" data="00000001"/>
                </key>
            </key>
                <key name="Apps" modified="2013-10-19 18:24:14" build="131017">
                <value name="Count" type="dword" data="00000000"/>
            </key>
                <key name="Colors" modified="2013-10-19 18:24:14" build="131017">
                <value name="Count" type="dword" data="00000000"/>
            </key>
        </key>
    </key>
</key>
3
  • Seems like your environment does not contains %HOMEPATH% variable. Check it. And how do you start PowerShell? What ConEmu version you are trying?
    – Maximus
    Oct 19, 2013 at 15:40
  • @Maximus You're right CMD does have %HOMEPATH% PowerShell3/ConEmu does not. I will add my settings export XML to the question. I am using version 131017. Oct 19, 2013 at 17:26
  • Wondering, why users trying to use 32-bit powershell in 64-bit OS?
    – Maximus
    Oct 19, 2013 at 20:14

1 Answer 1

0

You are trying to use 32-bit PowerShell in 64-bit OS. It is not a ConEmu problem, but only your configuration. Use proper 64-bit PowerShell.

%SystemRoot%\system32\WindowsPowerShell\v1.0\powershell.exe
1
  • Aha! That was it! I didn't realise I had a 32-bit version at all. Oct 19, 2013 at 21:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .