9

I just upgraded to 8.1 and now none of the Metro apps start.

The issue is that if I start any metro app, including the Store and PC Settings they immediately fail. The classic desktop is fine, as are standard programs, it's just the metro apps.

If I look in the system event log I see errors like this:

Activation of application winstore_cw5n1h2txyewy!Windows.Store failed with error: This application does not support the contract specified or is not installed. See the Microsoft-Windows-TWinUI/Operational log for additional information.

In addition the tiles in metro have a small cross icon on them:

enter image description here

I suspect that my Live ID (which I somehow managed to skip during update) is not set properly and consequently none of the online stuff works. But how do I fix this? I can't start PC settings, I can't start store. I see no way in the classic desktop of setting these things. I don't want to have to reinstall for this. Is there a simple fix?

Edit: More people with the same problem. And more here.

Edit 2: I created a Windows 8.1 Pro DVD (a trial to do all by itself) and the Refresh option didn't fix the issue either. Eventually I just bit the bullet and did a reset.

  • Its very likely that unless you have a recovery disk you might be out of luck. Have you tried the normal fixes for Windows 8 system integrity issues? eightforums.com/tutorials/… – Ramhound Oct 19 '13 at 17:31
  • try all steps from here: blogs.technet.com/b/askperf/archive/2013/10/11/… – magicandre1981 Oct 19 '13 at 18:20
  • I'm having the exact same issue and have tried every step mentioned on every other page I can find. Please post back if/when you find an answer. – Morinar Oct 20 '13 at 1:50
  • 1
    As far as I can tell nothing on blogs.technet.com is relevant. In fact I can't even run wsreset.exe (the last resort of the article) because it pops up a "ms-windows-store:PurgeCaches The application didn't start." error. – locka Oct 20 '13 at 8:48
  • 1
    In my case running "powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml" and then wsreset as suggested in one of the links has helped. I'm posting it here to document it as a solution that has worked for someone. – Andrew Savinykh Dec 8 '13 at 23:37
5

The fix for this is EASY.. It's a permission problem

Go to C:\ProgramFiles

unhide hidden and system folders

Then you will see WindowsApps

If you can't modify it , seize permission for the Administrators group and Add FULL control to ALL APPLICATIONS PACKAGES. Reboot the system when done

This fixes it RIGHT UP.... but it does leave a security hole as it gives all applications FULL permissions to this folder.. So in the RARE case you had an app go crazy, it could thrash the metro apps folder :)

Best thing to do is restore from backup...

Everyone should have system restore points, file restore and image backups or a 3rd party solution to back up to a date before things went wonky

If you don't have these, just fudge the permissions.... this works for 8 and 8.1

If anyone suggests Erasing, refreshing, etc your system, ESPECIALLY a MS tech, tell them no thanks... that ONLY.. and I repeat ONLY A LAST DITCH EFFORT

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.