Yesterday, I installed java from here. I set firefox click to play. about:config click to play - true. I restarted(just in case). That same day I tried to go to this verify page on java.com FF was giving me a green tick. I figure/figured it had to run a java applet to verify, and so click to play wasn't working.

Chrome for example, with click to play, won't get as far as a green tick. So it looks like FF's click to play isn't functioning there. Though Chrome is also a bit odd, because regardless of whether click to play is set or not, it temporarily blocks it and a button comes up near the address bar where I can run it image description
So I can't quite tell what effect click to play has on that page.

That was yesterday. I tried now today. Chrome behaves as it did but from FireFox I get

Firefox --> this message from firefox
Which looks like it blocked it on the basis of its own criteria of it being unsafe. Rather than just blocking it because I told it to function with 'click to play' thus to block any plugin's 'pluglett'(if I may call it that!) unless I click.

So, I don't see the explanation for either behaviour. It's possible my memory has failed me, because i'm talking about what happened yesterday, which I can't entirely repeat today. Also, i'd guess that Chrome, never runs java applets automatically even when told to run them automatically, you have to click run in the bar at the top, and then after that if the first time, it prompts again if you want to run it and you have to click run, so an inefficient form of click to play is applied specially for java applets. Whereas Chrome's click to play being on or off, will have an effect on adobe flash 'pluglets'. Firefox though is more strange. It seems to have blocked the applet on the basis of its content. enter image description here
Or perhaps, blocked the plugin on the basis of the plugin.

I'm not worried about the applet being insecure.. as it's from java.com My issue is more with click to play performing and how to see when it is performing. It seems how click to play handles java, is a bit funny.

In fact I just set click to play to true, in FF, and restarted just in case, and it is still displaying youtube's adobe flash videos.

I think I can see it is functioning in Chrome, and just doesn't operate in regard to java applets, as java applets are blocked unless permission is given, even without click to play. But in FF I just can't see it functioning at all, not even with youtube videos.


This is Firefox blocking the add-on "for your protection". It is not a click-to-play issue.

You can test click-to-play by setting that property for some other plugin, e.g. Flash, and checking if that asks for a click.

Firefox has been a bit draconian recently in its habit of blocking Java. Whether this is a good thing is not for me to say.

  • the property doesn't say it's per plugin and I don't see settings suggesting it is. i've set the option click to play to true, and it's still showing videos in adobe. so I guess it's not functioning for me for some reason – barlop Oct 19 '13 at 17:56
  • by "per plugin" I mean java plugin click to play on. adobe flash plugin click to play off e.t.c. You said " setting that property for some other plugin," But the property you mention plugins.click_to_play = True, doesn't distinguish between one plugin and another so isn't on a per plugin basis, but on all plugins. Or is it? – barlop Oct 20 '13 at 22:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.