6

The problem

On the VMware Knowledge Base it reads:

When I start a virtual machine, I see a message box warning that says I do not have VMware Tools installed or I do not have the latest version of VMware Tools installed. I already have the latest version of VMware Tools installed or I don't wish to install the VMware Tools at this time. Can I turn off this warning message?

They suggest a neat per-machine solution based on editing a key in the virtual machine's configuration file.

Open your VM config file

If you know how to open a virtual machine's configuration file, skip to next step.

In VMWare Player select a virtual machine and hit Ctrl D. You get the virtual machine settings dialogue. Switch to the "Option" tab and you can read the virtual machine name and working directory.

Go to the working directory and you find name.vmx, where name is the VM name: this is the configuration file.

VMware suggested solution

Add the following line anywhere in the configuration file:

tools.remindInstall = "FALSE"

Despite I set this key as suggested in the vmx config file, VMware Player keeps prompting to download VMware tools.

4

Despite what suggested in the VMware Knowledge Base, I solved the problems setting (not one but) two keys:

tools.remindInstall = "false"  
tools.upgrade.policy = "manual"

While they say: "do not have VMware Tools installed or ... do not have the latest version", the first key addresses only the installation and second the obsolete version.

3
  • Sorry, but i have to downvote this. It does not work. The popup still appears in VMWare Workstation 16 player. – steven Jan 19 at 12:32
  • Be happy. I cannot downvote here. But take a look at my answer, we need to disable it in Player > File > Preferences, now. – steven Jan 19 at 12:39
  • @steven: Have you seen the date, Steven? It was 8 years ago Steven. I'll be surprised if things were still the same today. However I can't help you as I don't use the product in this days. – antonio Jan 19 at 13:31
1

Done all of this, still the vmware player makes the annoying popup of installing latest tools every time I resume the machine from suspended state.

Any other tips?

0

The accepted answer seems not to work any more. With VMWare Workstation Player 16 I had to disable it in the preferences.

Player > File > Preferences...

In the "Software updates" group i had to uncheck the "Check for software components as needed" option.

After that the modal does not appear any more.

-1

On VMware Workstation 10.0.0.7, if you already have Tools installed and are still getting prompted to download and install, this seems to have worked for me after a couple restarts of the VM :

Remove this if you see it

toolsInstallManager.updateCounter = "1"

Add this:

tools.remindInstall = "FALSE"

Regards . . .

1
  • You don't really add anything that hasn't already been stated by the accepted answer. – Ramhound Apr 14 '16 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.