I access the Internet through an HTTP proxy firewall at college. And I need to login to a computer, via SSH, which is outside our network. I tried it as Linux command and on Windows using PuTTY. I also configured PuTTY to use our server's address. But still, "Proxy error: 403 forbidden" pops up. They must've blocked SSH access to outside systems. (college systems as accessible).

I can SSH a web server (not the proxy server) at the college, which I use to browse proxy-free by tunneling. Now this server allows to browse restricted sites, but still no SSH.

Any workaround, please?


It may be that the proxy is only allowing access to HTTP/HTTPS ports (80 or 443). I've worked around that by changing the SSH server to listed on port 443. That made the proxy I had to go through allow the connection, but if you can't change the SSH server then you may be out of luck.


If you can bypass the proxy for web, you can bypass it for SSH by tunneling SSH:

ssh -L 55555:remote-computer-to-ssh-to:22 login@webserver

and once that's in place:

ssh -oPort=55555 remote-login@localhost

This will give you an SSH tunnel to the webserver machine, which then forwards your SSH traffic to the remote machine.


@blahdiblah from what I understand his problem is not SSHing to the local webserver, its SSHing out of his network.

If they are blocking outgoing connections to port 22 it doesnt matter were he tries to SSH from, it will be blocked. Unless the firewall would be setup to allow the webserver to initate an outgoing connection on port 22 but i doubt it.

The way I see it is what shf301 said, you need to change the port on your SSH server to something they wont block, like 443 or 80 then, you will have to SSH to the websrver and from there ssh to your outside server.

Let us know how you fix it.

Good luck.

  • I think you should consider how does this help with the original question. Does it actually address the problem at hand? – user260419 Apr 15 '14 at 18:43
  • blahdiblah is misinforming the OP by suggesting he should be able to forward his ssh connection from the webserver to his server outside the network. The OP already mentioned he is unable to SSH outside the webserver. Most likely SSH is being blocked by their firewall either by port or layer 7 filtering. Which brings us back to changing the port as mentioned by shf301. In case of proper layer 7 he's most likely screwed as the firewall inspects the packets to identify which protocol is being used regardless of the port. In all certainty your post and this reply are definitely addressing nothing – TCZ Apr 22 '14 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.