0

I have configured Tasks Scheduler to wake up Windows/PC at certain times; however, the computer does not wake up after extended hours of sleep.

If I change the trigger configuration time to:

  • Sleep at: 7AM and
  • Wake Up at 7:15AM

and manually put the computer to sleep, it works, but it does not work if I set it as follows:

  • Sleep at 1:00AM and
  • Wake up at 7:00AM

and let the computer sleep on its own.

Similarly, when I manually put the computer to sleep by doing Start-->Shutdown-->Sleep, the process works, but it does not work if the computer sleeps on its own. There are no Hibernate Options. The computer is on a domain.

Here is my configuration:

Advance Sleep Settings:

  • Sleep: Never
  • Wake Up timers: On

General Settings:

  • Run with Highest Privileges
  • Run weather user is logged on or not

Triggers:

  • Daily, wake up at 7AM
  • Daily, Sleep at 1AM

Action:

  • For Wake up: Run program: cmd.exe
  • Optional Argument: /C"exit"
  • For Sleep: Run program: Rundll32.exe Powrprof.dll,SetSuspendState Sleep
    (This is in a bat file.)

Condition:

  • Wake the computer to run this task

Lastly, I also installed WakeUpOnStandBy as a back-up, but it too does not work, same as Task Scheduler.

I'm not sure what else to do?

  • Could you do a powercfg /a on the command prompt? It should say that Hibernate and Hybrid Sleep are both not available. – Rik Oct 21 '13 at 12:12
  • Forgot to mentioned, before I created the Task I had done the follow in the Command Prompt: powercfg -h off. I turned of Hybrid Sleep and Hybernation. This is the reason I do not see it in the Advance Power Settings. It's Off. – Amplitude Oct 21 '13 at 14:32
  • Yep. powercfg -h off does turn off both Hibernate and Hybrid sleep. Could you try giving the sleep command manually tonight and seeing if the computer wakes up in the morning. If not then it's a problem with your computer going to very deep sleep when off longer then a set period. (Maybe something in the BIOS). If it does wake-up there is a difference in manual sleep and the command given. There could also be a power outage at night where the computer really turns off. You could set "Resume on power on" in the BIOS to correct this. (but your computer will turn on at night in that case) – Rik Oct 21 '13 at 14:38
  • Great point. I will try that. This is killing me. I have checked the BIOS, it's a Lenovo ThinkCenter, did not see any thing suspicious. – Amplitude Oct 21 '13 at 14:45
  • Not sure this gives up anyting but powercfg/a gives me. S3 and S1 Sleep State available. Firmware does not support Standby State S2 and Hibernate. – Amplitude Oct 21 '13 at 15:54
1

Using this command in your batch file will cause a corruption and should not be used to put computer to sleep/suspend.

Rundll32.exe Powrprof.dll,SetSuspendState Sleep

The solution is to use Microsoft's Sysinternals, PSTools. Do a search and you will find the zip file to download on the Microsoft Technet site.

Follow these instructions exactly.

  1. Unzip the file and you will get a folder named Pstools
  2. Open that folder and copy ALL the files
  3. Go to C:\Windows\System32
  4. Past the files in that folder
  5. Launch the command prompt
  6. Type psshutdown and hit enter
  7. You will see a user acceptance window click accept. Close command prompt window
  8. Use the following in your batch file to put the computer to sleep:

\psshutdown \your computer name -d -t01

Note: Two backslashes before the psshutdown and not just one.

I will explain the switches: -D is to put computer to sleep/suspend. -t01 is the seconds it will wait before initiating sleep/suspend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.