Trying to upgrade to Windows 8.1 from my 64 bit windows 8 pro system.

My System config is as below:

Processor: AMD a6 - 3400M APU with Radeon(tm) HD Graphics 1.40 Ghz | 64-bit, x64 based processor RAM: 8.00 GB
Graphic Card: AMD Radeon HD 6470M 1 gb

I had daemon tools installed previously that I've already removed. I don't have any USB devices connected, using my internet over wifi.

Here is my Windows upgrade log.

Any help is appreciated.

P.S. Look for 20th October Afternoon details in Log.


  • Ensure that every connected peripheral (printers, phones, tablets, everything that isn't required to operate the computer) is unplugged and try the process again.
    – Flyk
    Oct 20, 2013 at 19:31
  • At what point did the error appear (after downloading, after installing, after restarting, after getting devices ready, transferring settings, etc., etc.)? Did a blue screen occur at any point?
    – Bob
    Oct 20, 2013 at 19:34
  • Please include all relevant information in the question. The link to Evernote might break and then the question doesn't make sense anymore. It is also much more time-consuming for people to answer your question if they have to visit external sites to understand it. Oct 20, 2013 at 20:10
  • @Bob Once the 8.1 was downloaded it asked for restart. Then set up process begin and at the 75% it gave me that error. The pc gets shut down at that point. No blue screen.
    – Sanket
    Oct 22, 2013 at 12:13
  • Flyk I made sure that there are no devices connected. @SanderSteffann Sorry for the inconvenience but putting complete windows log here wouldn't have been right either. Anyways what other details you need?
    – Sanket
    Oct 22, 2013 at 12:15

2 Answers 2


I got the same error when I tried to upgrade. From what I could figure out by searching online, this has happened to systems upgrading from 8.1 Preview to 8.1 with a machine that is dual-booting Linux and Windows.

Is this the case with you as well? If yes, maybe the only way is to roll back to Windows 8, and then try again. Another way you can do it is to replace GRUB2 with the stock Windows bootloader, and try again.

  • Vineet I neither had installed windows 8.1 preview (i've windows 8) nor do I have any dual-booting operating system. Although I've windows 7 installed in Virtual Box. So what you think about it? I've already disabled Virtualization from Bios setup.
    – Sanket
    Oct 24, 2013 at 18:21
  • Yeah, even I removed GRUB and re-installed the windows bootloader; same error. I thought the AGENT_INSTALL_FAILED error was because of the bootloader.
    – vineet
    Oct 24, 2013 at 23:42
  • Vineet I've got new error now.. just read my latest comment above. and let me know if you've any solution.
    – Sanket
    Oct 25, 2013 at 13:44
  • Yes, I read that. I'll try that tonight.
    – vineet
    Oct 25, 2013 at 15:15

I had the same issue, then I updated a few drivers and disabled/removed some devices I don't use anymore.

I think Western Digital's WD SES Device driver was causing these problems for me, so I removed it and restarted the setup process and it worked like a charm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .