Went to disk manager and setup a simple volume as drive D.

  • Installed windows 7 home premium
  • Disk manager: created a new simple volume "D:" in unallocated space.
  • Unable to until drive "C:" was made active.
  • Simple volume "D:" created.
  • On reboot got Bootmgr is missing
  • Booted from installation disk and tried:
  • > bootrec /fixboot
  • > The operation completed successfully
  • However still got bootmgr is missing
  • Tried:
  • > bootrec /RebuildBcd
  • > Successfully scanned Windows installations.
  • > Total identified Windows installations: 0
  • > The operation completed successfully
  • Still getting Bootmgr is missing

What are my options?

5 Answers 5


Boot to a dos prompt and from the Win7 DVD, in the boot folder, try running

bootsect /nt60 c:

Then run 'diskpart' and type type following

list disk
select disk 0  // Where disk 0 is where your C is
list partition
select partition 1 //Where partition 1 is C

Reboot your system

EDIT: By DOS prompt I mean off the win7 DVD to a console, whatever they have

  • This messed up my computer worse, I cant even access System recovery options on the DVD now...
    – Zombo
    Feb 1, 2013 at 16:41
  • FYI This is only relevant to old BIOS booted machines, not UEFI.
    – fret
    Oct 28, 2018 at 8:46

If Bootrec cannot locate any missing Windows installations, you must remove the BCD store, and then you must re-create it. To do this, boot to command prompt and type the following commands in the order shown below. Remember to press ENTER after each command.

bcdedit /export C:\BCD_Backup  
cd boot
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old  
bootrec /rebuildbcd

Finally, restart the computer.


Fixed it!

I had a similar problem with the bootmgr being installed on a different hard drive when the OS was installed on a RAID array. This brought a few other problems with having to go deeper into the wizards to "load drivers" then exit out and get back to the command prompt.

Here is what you do.

I tried the same options as listed above. PLUS

The real problem is that the OS is looking for the file Bootmgr but it's not there.

So to get it there you have to copy it from the Windows 7 DVD.

  1. **xcopy d:\bootmgr c:** (where D: is your CDrom)

  2. **xcopy d:\bootmgr.efi c:** (don't know if it needs this or not)

Then I ran the above options again. Then it finally booted successfully.

Cheers, Leighton


Wanted to put my 2 cents in.

If you created the system repair CD, boot into that CD and go through the repair functions. You may have to do this a couple of times, but it does work. I had the same problem.


  • Yes this worked for me. But some keys were that I had to physically remove the original drive that I had cloned the OS from (it had BOOTMGR on it). In this manner, the repair disk will not be able to keep updating the old drive and should write the new bootmgr to the new drive. Once the repair is complete the old drive can be re-connected. Finally update boot sequence to use the new drive.
    – crokusek
    Oct 11, 2013 at 8:03

I guess ms STILL can't get a windows setup right when there is more than one hd in the system?!!! This is nuts....

I have a raid array on its own controller, and 2 sata drives on the motherboard's controller. In the Win7 setup I supplied the raid driver, and the array appeared fine, and I nuked the partition and installed to it raw. (Setup doesn't have to do a full format anymore? That was wild!)

So on the first couple reboots, I left the dvd in the drive and the "press a key to boot from dvd" or similar message would time out, and the system would boot as expected. So later I finally take out the dvd and reboot, and I get a "can't find system disk" type of message (didn't actually say anything specific about bootmgr missing). Hhowever, I could boot fine again if I put the dvd in the drive and let the "press a key to boot from dvd" message time out.

(I keep thinking of the "trust me" apple commeercials at this point.)

So what I found later is that bootmgr file and Boot folder are on one of the sata drives, and not the raid drive. But this was after that drive not even appearing in explorer, I thought it got trashed by the setup! (Memories of windows installs past.)

In the end, I just disabled the sata controller altogether so the raid drive was the only drive in the system for setup to not get confused. Everything is fine now, system boots normally and with the sata drives back online.

BUT... bootmgr and Boot folder are not on the raid drive (C:)! They are on the same sata drive as before. I was rebooting fine before with the sata disabled, so they must have been on C: and then either got moved to the sata drive, or they were detected on the sata drive and deleted from C:???? What gives!?

So I guess the only way to be sure is disabled the sata controller again and see if 7 will still boot from the raid. Damn weird. (Hey, it's still windows, they say. LOL)

Not the answer you're looking for? Browse other questions tagged or ask your own question.