Here is what I do:

  1. restart machine with Windows 8.1
  2. determine "EFI System" partition with the Disk Management utility
  3. run command prompt as administrator
  4. type diskpart
  5. type select disk 0 then select partition 2 then assign
  6. open windows explorer windows+e
  7. refresh if the drive is not showing F5
  8. try to open drive by double clicking

What I expected to happen:

I can at least look at my EFI partition files.

What happened:

after double clicking

after clicking continue

after clicking continue

after clicking "security tab" link, no security tab

after clicking security tab, no security tab

What do I need to do to access my EFI partition on Windows 8.1?

The reason why you can't access it on Windows Explorer (File Explorer) is because by default it does not run with administrative privileges. If you let's say kill Explorer and execute it again from an elevated command prompt then you will have access to the EFI partition through File Explorer.

First open an elevated command prompt and give the EFI partition a drive letter, you can do it with mountvol as shown in jmiserez's answer (recommended) or with diskpart. In the following example the EFI partition is on disk 0, partition 1 and will be assigned to letter b:

diskpart
list disk
select disk 0
list partition
select partition 1
assign letter=b
exit

Now kill the File Explorer process and start it with administrative privileges:

taskkill /im explorer.exe /f
explorer.exe

Now you can access the EFI partition with File Explorer.

enter image description here

Note that the EFI partition is a FAT32 file system partition. FAT partitions don't have the Security tab, this is a NTFS feature only.

  • 1
    I'm curious, why does it matter? Explorer seems fine accessing other folders with only admin rights, like system volume information. – Milind R Jan 18 '14 at 19:01
  • I am using a limited user account. Killing explorer.exe and starting it from the elevated command prompt resulted in a dysfunctional GUI, with only a start button, without any desktop, icons, or any way of using file explorer. Looks like this has to be done in a real admin account. – Milind R Jan 24 '14 at 11:36
  • 1
    @MilindR, Go to %windir% find for explorer.exe, right click that and run as administrator. – Pacerier Apr 24 '15 at 5:02
  • 5
    This didn't work for me on Windows 10, after launching explorer as admin it still said that I don't have permissions :( – szx Aug 4 '17 at 6:21
  • @szx A way I've found convenient to quickly browse the files on the EFI partition is to open an app such as Notepad as administrator, then use the Open file dialog. – Dan Mirescu Jan 27 at 18:50

The official way of mounting the EFI partition is

mountvol b: /s

where b: is a drive letter of your choosing. You can remove the mapping with:

mountvol b: /d

You still need to launch explorer.exe with administrative privileges in order to see the mountpoint (kill explorer.exe, then launch one from an elevated command prompt)

up vote 7 down vote accepted

One way I found is to open it in the administrator command prompt:

type E: then you can browse around and edit the files

I tried everything and nothing worked on explorer for me.
I tried killing and running explorer from elevated cmd, and also tried the same with PowerShell and nothing worked.
I could however edit inside cmd and powershell but not GUI/Explorer.

It is very odd but if you Download Explorer++ it works.
Extract it and run as admin

From this post:-

It took me some time to find a workaround so I thought I share it.

1- Mount the EFI partition to a free mount point: -- Run command prompt as administrator -- Type "mountvol X: /s" (without the quotes, X being an unused mount point)

2- Use Explorer++ (Free, Open Source app) to manipulate the files on the partition: -- Run Explorer++ with administrative privileges

Hope you find this useful

Press Start and type gpedit.msc and press Enter This will open your Group Policy Editor.

Expand Administrative Templates

enter image description here

Expand Windows Components -> File Explorer

enter image description here

Locate Remove Security tab in the right pane and double click to open

enter image description here

Select the Disabled radio button and press OK

Now check for your security tab :)

enter image description here

Now, you can add yourself Read/Write permissions or just take the ownership

  • 2
    My installation of Windows does not seem to have the command gpedit.msc, I think it might be because I am not running Windows 8.1 Pro. – RyanTM Oct 21 '13 at 3:42
  • 7
    -1 FAT32 does not have security. – kinokijuf Jan 9 '14 at 17:45

protected by Community Oct 8 '16 at 21:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.