Here is what I do:

  1. restart machine with Windows 8.1
  2. determine "EFI System" partition with the Disk Management utility
  3. run command prompt as administrator
  4. type diskpart
  5. type select disk 0 then select partition 2 then assign
  6. open windows explorer windows+e
  7. refresh if the drive is not showing F5
  8. try to open drive by double clicking

What I expected to happen:

I can at least look at my EFI partition files.

What happened:

after double clicking

after clicking continue

after clicking continue

after clicking "security tab" link, no security tab

after clicking security tab, no security tab

What do I need to do to access my EFI partition on Windows 8.1?

5 Answers 5


The official way of mounting the EFI partition is

mountvol b: /s

where b: is a drive letter of your choosing. You can remove the mapping with:

mountvol b: /d

You still need to launch explorer.exe with administrative privileges in order to see the mountpoint (kill explorer.exe, then launch one from an elevated command prompt)


The reason why you can't access it on Windows Explorer (File Explorer) is because by default it does not run with administrative privileges. If you let's say kill Explorer and execute it again from an elevated command prompt then you will have access to the EFI partition through File Explorer.

First open an elevated command prompt and give the EFI partition a drive letter, you can do it with mountvol as shown in jmiserez's answer (recommended) or with diskpart. In the following example the EFI partition is on disk 0, partition 1 and will be assigned to letter b:

list disk
select disk 0
list partition
select partition 1
assign letter=b

Now kill the File Explorer process and start it with administrative privileges:

taskkill /im explorer.exe /f

Now you can access the EFI partition with File Explorer.

enter image description here

Note that the EFI partition is a FAT32 file system partition. FAT partitions don't have the Security tab, this is a NTFS feature only.

  • 1
    I'm curious, why does it matter? Explorer seems fine accessing other folders with only admin rights, like system volume information.
    – Milind R
    Jan 18, 2014 at 19:01
  • 2
    @MilindR, Go to %windir% find for explorer.exe, right click that and run as administrator.
    – Pacerier
    Apr 24, 2015 at 5:02
  • 14
    This didn't work for me on Windows 10, after launching explorer as admin it still said that I don't have permissions :(
    – szx
    Aug 4, 2017 at 6:21
  • 1
    @szx A way I've found convenient to quickly browse the files on the EFI partition is to open an app such as Notepad as administrator, then use the Open file dialog. Jan 27, 2018 at 18:50
  • 2
    after killing explorer type explorer.exe /nouaccheck. works for me win10
    – kcdwayne
    Sep 16, 2021 at 15:23

One way I found is to open it in the administrator command prompt:

type E: then you can browse around and edit the files

  • 1
    Yeah, if magic is real, this is it. you can use XCOPY command to transfer
    – Jovylle
    Mar 4, 2021 at 9:19

I tried everything and nothing worked on explorer for me.
I tried killing and running explorer from elevated cmd, and also tried the same with PowerShell and nothing worked.
I could however edit inside cmd and powershell but not GUI/Explorer.

It is very odd but if you Download Explorer++ it works.
Extract it and run as admin

From this post:-

It took me some time to find a workaround so I thought I share it.

1- Mount the EFI partition to a free mount point: -- Run command prompt as administrator -- Type "mountvol X: /s" (without the quotes, X being an unused mount point)

2- Use Explorer++ (Free, Open Source app) to manipulate the files on the partition: -- Run Explorer++ with administrative privileges

Hope you find this useful

  • 1
    I should mention, that any file manager (Total Commander, Double Commander, FAR etc.) that can be explicitly run with admin privileges would handle opening EFI partition.
    – tm-
    May 27, 2019 at 14:07
  • as of this date, this doesn't work
    – davejoem
    Dec 12, 2020 at 20:45
  • As of this date, this DOES work.
    – OMGJL
    Jan 21, 2022 at 5:28

Press Start and type gpedit.msc and press Enter This will open your Group Policy Editor.

Expand Administrative Templates

enter image description here

Expand Windows Components -> File Explorer

enter image description here

Locate Remove Security tab in the right pane and double click to open

enter image description here

Select the Disabled radio button and press OK

Now check for your security tab :)

enter image description here

Now, you can add yourself Read/Write permissions or just take the ownership

  • 4
    My installation of Windows does not seem to have the command gpedit.msc, I think it might be because I am not running Windows 8.1 Pro.
    – RyanTM
    Oct 21, 2013 at 3:42
  • 12
    -1 FAT32 does not have security.
    – kinokijuf
    Jan 9, 2014 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .