Upgrading from Windows 8 to Windows 8.1 via the Store upgrade path has screwed my SkyDrive. The C:\Users\<user name>\SkyDrive folder is empty (it only has single file desktop.ini). When I open the native (Store) SkyDrive app, I see "This location can't be found, please try later". I'm glad to still have my files alive online in my SkyDrive account.

I tried disconneting from / reconnecting to my Microsoft Account with no luck.

Anyone has an idea on how to fix this without reinstalling/refreshing Windows 8.1?

From Event Viewer:

Faulting application name: skydrive.exe, version: 6.3.9600.16412, time stamp: 0x5243d370
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0x00000000
Fault offset: 0x0000000000000000
Faulting process ID: 0x4e8
Faulting application start time: 0x01cece256589c7ee
Faulting application path: C:\Windows\System32\skydrive.exe
Faulting module path: unknown
Report ID: {...}
Faulting package full name: 
Faulting package-relative application ID: 


The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID 
 and APPID 
 to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Never was a big fan of in-place upgrade anyway, but this time it was a machine which I use for work, with a lot of stuff already installed on it. Shouldn't have tried to upgrade it in the first place, but was convinced Windows 8.1 is a solid update. Another lesson learnt.

  • create a dump file and share the dump: pastebin.com/zKuJvw57 – magicandre1981 Oct 21 '13 at 17:08
  • @magicandre1981, thank you, but I went ahead and reinstalled it from scratch. I wouldn't trust the system with broken integrity like that, anyway. – avo Oct 22 '13 at 0:29

Try the following registry script:

Windows Registry Editor Version 5.00
| improve this answer | |
  • I have already reinstalled Windows, but +1 for trying to help. – avo Dec 5 '13 at 4:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.