1

At work, our ISP has gone down, 3 days running. A company next door has kindly provided us with access to their wireless network, and I'd like to get our internal mail server (win 7) to become online via that wireless connection, while being accessible from within the LAN, but I'm struggling with the windows configuration. Our company's LAN subnet (wired interface) sits on 192.168.0. Neighbour's wireless subnet 192.168.1.

I've tried bridging the connections but that disconnects the mail server from the Internet connection and the LAN. what do I have to do achieve this networking configuration?

Kind regards, Wolfgang

1

I may be confused about your situation.. but to my knowledge you simply need either a PC or laptop connected to the neighbour wifi, and let that PC/laptop to do Internet Connection Sharing.

Internet Connection Sharing can share the WiFi it is connected to, to the LAN it is connected to. Simply connect to the WiFi, go under Network Connections (or Network and Sharing Center) and go under "Change Adapter Settings". Choose your WiFi connection and right click on it, and there should be a "Sharing" tab, and Share this internet connection.

Once done, set the LAN connection to your own LAN IP address (somewhere accessible to your LAN, maybe 192.168.0.100), then set any PC that requires internet access with gateway to 192.168.0.100 as their gateway.

If my guess is off the mark, please let me know and I'll edit as needed.

  • Darius,thanks for the quick reply, I hadn't thought of using connection sharing, I'll give it a try. Would that work on the mail server itself? I'll report back! – Wolfgang Haak Oct 21 '13 at 15:37
  • @WolfgangHaak You don't have to do the Internet Connection Sharing on the Mail server itself. Just the PC/Laptop connected to the WiFi. Your mail server (or the rest of your network) just need to have Gateway pointed to that PC/Laptop connected to the WiFi. It is a bit tedious to do it one by one of course, but only until your ISP connection is fixed. – Darius Oct 21 '13 at 15:56
  • I've moved the wifi adaptor to a new computer as you suggested, and set up ICS, after that I had to manually reconfigure the network of the LAN adaptor back to 192.168.0.x as windows changes it to 192.168.137.x as soon as I enabled ICS. Problem solved! – Wolfgang Haak Oct 21 '13 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.