8

Since upgrading to 8.1, Windows will shut down my hard drive bay connected by USB after about 10 minutes. I didn't have this issue in Windows 8 as I just went in and changed the hard drive sleep time to Never. However Windows 8.1 seems to be ignoring this and powering off my USB drives. Any ideas on how to fix this?

  • which machine ? Which model ? – Fahad Saleem Oct 22 '13 at 7:14
  • Home made computer. – Rumel Oct 23 '13 at 5:33
  • Now this would be too silly to ask but I hope you have tried different ports – tumchaaditya Oct 29 '13 at 6:33
  • I have USB 3 and USB 2 – Rumel Oct 29 '13 at 20:12
  • 1
    I cannot answer due to reputation < 10; however, this is a bug in Windows 8.1 and you can find out more here: answers.microsoft.com/en-us/windows/forum/… – Michael Mortensen Oct 30 '13 at 23:18
3

I came across the blog post Help! After installing Windows 8.1, my USB drive disappears or file transfers stop unexpectedly… when trying to resolve problems with my Seagate Expansion 3 TB drive which would power down after several minutes with no access despite power save setting set to "never" shut down.

This began happening after doing a fresh install of Windows 8.1. I followed instructions concerning a registry hack and the problem has been fixed.

  • +1: Setting the registry key seems to be the only thing that works in my case. Settings in "Power Options" as well as power settings for the USB Root Hubs didn't seem to do anything. – Ryan Nov 3 '13 at 16:36
  • Thank you, that has resolved the issue for myself as well. +1. – headkase Dec 6 '13 at 10:10
  • According to the updated reference, this is no longer required - "The registry workaround described in this blog is no longer required. A major Windows update published on 2014-04-08 reverts the USBSTOR.SYS driver behavior to 8.0." – Peter Mortensen Apr 15 '15 at 9:55
  • Link only answers are not acceptable here, please add important parts in the link to your answer please – Moab Aug 5 '16 at 0:05
  • Answers like this are frustrating, in this case, I am interested in the solution you submitted, but the website failed to load for me. – Ramhound Aug 5 '16 at 7:07
2

Go into Device Manager, click on Universal Serial Bus controllers, right click (or Alt + Return) on each of the entries labeled USB Root Hub, choose Properties, and click on tab Power Management. Make sure the check mark in "Allow computer to turn off device" DOES NOT HAVE A CHECK.

Do that for every USB Root Hub device in Device Manager. Your external hard disk drive will no longer shut off.

Screenshot from Windows Device Manager

  • Awesome I'll try that out when I get home tonight. – Rumel Oct 22 '13 at 19:47
  • That did not solve the problem. – Rumel Oct 24 '13 at 17:14
  • Same with me .. it did not solve the problem at all :( – Jurgen Oct 24 '13 at 17:40
  • @Rumel - Helps if you provide more detail then "it didn't work" did it make any difference? – Ramhound Oct 27 '13 at 8:48
  • 1
    There was no difference at all. They still shut off after a bit. – Rumel Oct 27 '13 at 20:47

protected by Community Oct 26 '13 at 7:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.